summaryrefslogtreecommitdiff
path: root/dev-python/QtPy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-python/QtPy
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/Manifest4
-rw-r--r--dev-python/QtPy/QtPy-2.3.0.ebuild207
-rw-r--r--dev-python/QtPy/QtPy-2.3.1.ebuild2
3 files changed, 2 insertions, 211 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
index 099c32c5ffb3..8db5bf19bcf6 100644
--- a/dev-python/QtPy/Manifest
+++ b/dev-python/QtPy/Manifest
@@ -1,5 +1,3 @@
-DIST QtPy-2.3.0.tar.gz 53980 BLAKE2B 142694c3b10dc2ed46c168a063c0019928358d079dddfef0708ec8cabd782e206734bc0f680a7ee7309b483c56ecd739b3364061eaf190a1a9c9e41d940af202 SHA512 1fa3d52367fa70ca178a128f3cc95f333b1408dd88b9f9d15ef30b4c7f848a91df1626fa046667ce6bd6ee3f7a3909f1b3fb06b902eff26e1f058139eced73c6
DIST QtPy-2.3.1.tar.gz 56260 BLAKE2B 1b8d76879cc1f07b3633e6b25887ac4621ee3a8e9ebbcaa1f1f8c4f3fbcdae37bd5d659717bf89227d4ed6b5126554b329813aaee0b6be333c0cdc931cfb8d43 SHA512 9c738ec07e18852b67c30962fbc0ca48479eccff2a9f2ee9f4817c4ead5a8068d54aced58d632977163f180a584a9b7b2b68ea25e0577b92a262fef8eb576041
-EBUILD QtPy-2.3.0.ebuild 8326 BLAKE2B 08fe67f11f10cf1f41dbbf3eb48cecf4ec0b93efde7f39d7d04d4ccad527b2e906348bcd4861ac94a5e2e24cf0635fbe8e0f168eb1572a735b95877bb51cc372 SHA512 81d4aa3e55aede8a48733ada73bd754b78cf6058ec629c3965a81dc7cffafacf75f1155e951b240b38cebe8c562cf40ca2626ba794a70dbc538d3c25b4e32034
-EBUILD QtPy-2.3.1.ebuild 8329 BLAKE2B 001f74f38a0060c8c1bda8ec279f90b8a577eed78d80fa70e7b90b229c1ad5784762f69891fe6c3bd73f67b3b405ec3da27a15f8f407fc1bc3c62124dbf96b76 SHA512 b089481cf65def27db76d29c3458b90ad867e0f068eac990ebe1686a4e71ec070c423702e018bed9d0076fb168a70a40f044370875ffb1b5490051cb0d66ee50
+EBUILD QtPy-2.3.1.ebuild 8326 BLAKE2B 08fe67f11f10cf1f41dbbf3eb48cecf4ec0b93efde7f39d7d04d4ccad527b2e906348bcd4861ac94a5e2e24cf0635fbe8e0f168eb1572a735b95877bb51cc372 SHA512 81d4aa3e55aede8a48733ada73bd754b78cf6058ec629c3965a81dc7cffafacf75f1155e951b240b38cebe8c562cf40ca2626ba794a70dbc538d3c25b4e32034
MISC metadata.xml 2716 BLAKE2B 7c62f7b181608c56a8e9be69c05e2cb34e5f450682ea4e7ca6c4bff5f02cf4ff803d44dda356d2be3968464842d421b5ac7320fc4d08a430e7805f6e400a262f SHA512 62509ecf92f89453fea52a8c23accff778a5572b689428838d801470ab30f2e2cb85f9319a75afeb81c284d68fb2abe399714bb1410daa8ec896af1f17763347
diff --git a/dev-python/QtPy/QtPy-2.3.0.ebuild b/dev-python/QtPy/QtPy-2.3.0.ebuild
deleted file mode 100644
index b3033047630e..000000000000
--- a/dev-python/QtPy/QtPy-2.3.0.ebuild
+++ /dev/null
@@ -1,207 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
-HOMEPAGE="
- https://github.com/spyder-ide/qtpy/
- https://pypi.org/project/QtPy/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-
-_IUSE_QT_MODULES="
- designer +gui help multimedia +network opengl positioning
- printsupport qml quick serialport +sql svg testlib
- webchannel webengine websockets +widgets +xml
-"
-IUSE="+pyqt5 pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="|| ( pyqt5 pyqt6 pyside2 pyside6 )"
-
-# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5 only )
-# dbus? ( pyqt5 only )
-#
-# 3d? ( pyside2 only )
-# charts? ( pyside2 only )
-# concurrent? ( pyside2 only )
-# datavis? ( pyside2 only )
-# scxml? ( pyside2 only )
-# script? ( pyside2 only )
-# scripttools? ( pyside2 only )
-#
-# location? ( pyside2 and pyqt5 only )
-# sensors? ( pyside2 and pyqt5 only )
-# speech? ( pyside2 and pyqt5 only )
-# x11extras? ( pyside2 and pyqt5 only )
-# xmlpatterns? ( pyside2 and pyqt5 only )
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt5[positioning?,printsupport?,serialport?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
- qml? ( dev-python/PyQt5[declarative] )
- quick? ( dev-python/PyQt5[declarative] )
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt6[positioning?,printsupport?,qml?,quick?,serialport?,sql?]
- dev-python/PyQt6[svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
- webengine? ( dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets?,quick?] )
-
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
- dev-python/pyside2[positioning?,printsupport?,qml?,quick?,serialport(+)?]
- dev-python/pyside2[sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,xml?]
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyside6[positioning?,printsupport?,qml?,quick?,serialport?]
- dev-python/pyside6[sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside6[widgets?,xml?]
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[dbus,designer,gui,help,multimedia,network,opengl]
- dev-python/PyQt6[positioning,printsupport,qml,quick,quick3d,serialport]
- dev-python/PyQt6[sql,ssl,svg,testlib,webchannel,websockets,widgets,xml]
- dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets,quick]
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[concurrent,dbus,designer,gui,help,multimedia]
- dev-python/pyside6[network,opengl,positioning,printsupport,qml]
- dev-python/pyside6[quick,quick3d,serialport,sql,svg,testlib]
- dev-python/pyside6[webchannel,webengine,websockets,widgets,xml]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
- # Disable Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyqt6; then
- sed -i -e "s/from PyQt6.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside6; then
- sed -i -e "s/from PySide6 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide6.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
-}
-
-python_test() {
- # Test for each enabled Qt4Python target.
- # Deselect the other targets, their test fails if we specify QT_API
- # or if we have disabled their corresponding inherit in __init__.py above
- if use pyqt5; then
- einfo "Testing with ${EPYTHON} and QT_API=PyQt5"
- QT_API="pyqt5" virtx epytest \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6]
- fi
- if use pyqt6; then
- einfo "Testing with ${EPYTHON} and QT_API=PyQt6"
- QT_API="pyqt6" virtx epytest \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6] \
- --deselect qtpy/tests/test_qtsensors.py::test_qtsensors
- # Qt6Sensors not yet packaged and enabled in PyQt6 ebuild
- fi
- if use pyside2; then
- einfo "Testing with ${EPYTHON} and QT_API=PySide2"
- QT_API="pyside2" virtx epytest \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6]
- fi
- if use pyside6; then
- einfo "Testing with ${EPYTHON} and QT_API=PySide6"
- QT_API="pyside6" virtx epytest \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
- --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
- --deselect qtpy/tests/test_qtsensors.py::test_qtsensors
- # Qt6Sensors not yet packaged and enabled in PySide6 ebuild
- fi
-}
-
-pkg_postinst() {
- elog "When multiple Qt4Python targets are enabled QtPy will default to"
- elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
- elog "This can be overridden with the QT_API environment variable."
-}
diff --git a/dev-python/QtPy/QtPy-2.3.1.ebuild b/dev-python/QtPy/QtPy-2.3.1.ebuild
index bcd54d8d87a8..b3033047630e 100644
--- a/dev-python/QtPy/QtPy-2.3.1.ebuild
+++ b/dev-python/QtPy/QtPy-2.3.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
_IUSE_QT_MODULES="
designer +gui help multimedia +network opengl positioning