summaryrefslogtreecommitdiff
path: root/dev-python/QtPy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/QtPy
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/Manifest4
-rw-r--r--dev-python/QtPy/QtPy-2.0.0.ebuild140
-rw-r--r--dev-python/QtPy/QtPy-2.0.1.ebuild2
3 files changed, 2 insertions, 144 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
index be6e396f2b29..d6c3e7ba9ff2 100644
--- a/dev-python/QtPy/Manifest
+++ b/dev-python/QtPy/Manifest
@@ -1,5 +1,3 @@
-DIST QtPy-2.0.0.tar.gz 39628 BLAKE2B bc1b2cf975c3457cb026016854ec70e0aa3247c1234643dbf95681f655678e43ba0200b26e16a0b9eafd6fb373c1f876d9a54458ceb9b9b035ad463b7874db2c SHA512 95855c305da7f54850bcb6297a1f12ceda79eaf6d9b01771b1391d2d7b07b8f690e134cc2d52417bcc320395dce8c1f7f5c6ccadf2939db196e0ed5441215d5a
DIST QtPy-2.0.1.tar.gz 43047 BLAKE2B 66625852e75fbfcf0bf96e740754ca26b6d5226dd5450d0274cf6dc875cba18e5ed8e339c8c7ad084ffa9b135f19447e087b338690ec521205316c4f22f09197 SHA512 5d482b0a5bd2be67a0fabccf98a9dedf28ef328641c8c976e2274d4a5afb14b9fefce251e80496ed54425dcb3da24984c6c36308db0bfc810ea2142528ad88fd
-EBUILD QtPy-2.0.0.ebuild 5215 BLAKE2B 23261bb6e3a1818b8032c4bb87ee501a12aac8e9595c2aaf17cfa516d8db2f1fd6410af388601fed1a6f9daf8323300303deda7e434dfd7f152db4bed742ca77 SHA512 aca9dc14dd97d1ab4719f47e110fdd91ed12c97f3f83dae91f3d2888650af57917b251da3a85dbcfae6fbedc1dd270450ea0ce63cc2385e70d59b0f4f6b9ca4d
-EBUILD QtPy-2.0.1.ebuild 5218 BLAKE2B 9a171da96f211d963e26654e14ed739a9c5c3c3389cce25b591235fffceb65dd4b51985409d6afff7bdb2facfae4b3388efc89acbb9f5fcbb558900bce53d457 SHA512 6f4a041717e98025b11e27af4a76ad80f067887ae63f7cb06a226b145de1aa7a22c0e5dd3adb484b491f245ca3b5e849505ab738b4b0051c9e2c74566a17e73d
+EBUILD QtPy-2.0.1.ebuild 5215 BLAKE2B 23261bb6e3a1818b8032c4bb87ee501a12aac8e9595c2aaf17cfa516d8db2f1fd6410af388601fed1a6f9daf8323300303deda7e434dfd7f152db4bed742ca77 SHA512 aca9dc14dd97d1ab4719f47e110fdd91ed12c97f3f83dae91f3d2888650af57917b251da3a85dbcfae6fbedc1dd270450ea0ce63cc2385e70d59b0f4f6b9ca4d
MISC metadata.xml 2904 BLAKE2B f951ee9cfb1e57da9c1b528015cf56bf72e36fbcea6973f5bd237e86c8039d82d9700166ab76773b9bfbc8e499df492994e5dd73aee0bb2d35914d36bcf1bd78 SHA512 e6e13d0c24f16379ac03711f02c5201d1ab28bcbbddd7063f0487bbaaeda99e5a2ef87f00d8df834d822c9230a50ddead93b44affccf07b80bfc275140f4e9ff
diff --git a/dev-python/QtPy/QtPy-2.0.0.ebuild b/dev-python/QtPy/QtPy-2.0.0.ebuild
deleted file mode 100644
index 9fcfb7eab3c3..000000000000
--- a/dev-python/QtPy/QtPy-2.0.0.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
-HOMEPAGE="https://github.com/spyder-ide/qtpy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-_IUSE_QT_MODULES="
- declarative designer gui help location multimedia network opengl
- positioning printsupport sensors serialport speech sql svg testlib
- webchannel webengine websockets widgets x11extras xml xmlpatterns
-"
-IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="|| ( pyqt5 pyside2 )"
-
-# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5 )
-# dbus? ( pyqt5 )
-#
-# 3d? ( pyside2 )
-# charts? ( pyside2 )
-# concurrent? ( pyside2 )
-# datavis? ( pyside2 )
-# scxml? ( pyside2 )
-# script? ( pyside2 )
-# scripttools? ( pyside2 )
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[declarative?,designer?,gui?,help?,location?]
- dev-python/PyQt5[multimedia?,network?,opengl?,positioning?]
- dev-python/PyQt5[printsupport?,sensors?,serialport?,speech(-)?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?]
- dev-python/PyQt5[x11extras?,xml(+)?,xmlpatterns?]
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
- dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
- dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
- dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
- declarative? ( dev-python/pyside2[qml,quick] )
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- )
- pyside2? (
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- default
- # Disale Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- fi
-
- # Disable outdated PyQt4 and PySide
- sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PyQt4.QtCore import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
- sed -i -e "s/from PySide.QtCore import/raise ImportError #/" qtpy/__init__.py || die
-}
-
-python_test() {
- if use pyqt5; then
- QT_API="pyqt5" virtx epytest
- fi
- if use pyside2; then
- QT_API="pyside2" virtx epytest
- fi
-}
-
-pkg_postinst() {
- if use pyqt5 && use pyside2; then
- ewarn "You have enabled both PyQt5 and PySide2, note that QtPy will default"
- ewarn "to PyQt5 unless the QT_API environment variable overrides this."
- fi
-}
diff --git a/dev-python/QtPy/QtPy-2.0.1.ebuild b/dev-python/QtPy/QtPy-2.0.1.ebuild
index 3013f6cdc707..9fcfb7eab3c3 100644
--- a/dev-python/QtPy/QtPy-2.0.1.ebuild
+++ b/dev-python/QtPy/QtPy-2.0.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm arm64 x86"
_IUSE_QT_MODULES="
declarative designer gui help location multimedia network opengl