summaryrefslogtreecommitdiff
path: root/dev-python/Rx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/Rx
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/Rx')
-rw-r--r--dev-python/Rx/Manifest4
-rw-r--r--dev-python/Rx/Rx-3.2.0.ebuild32
-rw-r--r--dev-python/Rx/metadata.xml3
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/Rx/Manifest b/dev-python/Rx/Manifest
index 53cb34b8d8f0..1a27bf397b6d 100644
--- a/dev-python/Rx/Manifest
+++ b/dev-python/Rx/Manifest
@@ -1,3 +1,5 @@
DIST Rx-3.1.0.tar.gz 890293 BLAKE2B 268f6df5450d1235d50f9aee5cd43fe6e229acf7b2ddab5f1f97e80594aeff7beaa280fe272ac9cc8b80dc6874f4bb76e438e94c09712f2c37e72d8d40f9f283 SHA512 1d9f6639ef08dc991326b95fcbf0978adea55b35acab653fc16bd94ccf2ad3a1515e8cb4e8d2ff38d7a506306e310394339a8651a2a02fa22bfb7f17d86297f1
+DIST RxPY-3.2.0.tar.gz 891490 BLAKE2B 9d4e72c20544f1c607fa28963193ca88d7d6f63c0e4a3faa4e3aafba6cce5bb0c1b99ca7a8fb62052adc3dc02b7ca71d4c190704f18819fbb2598a38b2ce86da SHA512 08a53344ea374b025e51ebf3a7de5ea4e83c7062d0c9a3370b795a56156c8aa068f2b3415f6e5e9e2424a11bcef53a412fd0667afb0016b58b7d2a741ea1007a
EBUILD Rx-3.1.0.ebuild 595 BLAKE2B 748493f5e36892ce9e1851cf8a29601e612a02f8550a1bfe1d393ff59435e20ec6c6c0c4d83d6626873a24eed1fb792e2005188e3076acbc36f050c1d1c9e0f8 SHA512 1cb18881a3c09553095a04c23995e5d2e66cd0d1a4eb6e390c7c67348f5d713e8f8592c04a2a3aa689f1fe5b84937ec5bd7d4866d6c40b232358cb7b96ee6246
-MISC metadata.xml 327 BLAKE2B c9349fc7bf783920d0f8469ea19b8cf475c4705d3499364ab79a6960e19c3458b7d2a18aa90a470b033003fe461f06d34d25206b702c835e5a311d698d4c2e95 SHA512 382a7e9dd6cf734155229b3acc48060b4d11f2e68b2fe906ad8508ea5de95b1adcd5d23d58b6ff4881f7d5c9f103e64b60787eaebbeff2db8f9b24188dab6395
+EBUILD Rx-3.2.0.ebuild 584 BLAKE2B 7a0a1213c358dc9d4630cb81993e2b2fc92ed95b4f886f6173ddab6b9db02e4494a68062b0780b11989c8321f9fe94d722e00e8a18f62f791f644da5fa040cb5 SHA512 db84008a1f254378eed449a45f585ab491cc303638deb0127a093e8968782a3a24ba87920b2a97f5eba08f33bf8c71bd313d9798a33635218662d0fc330e6700
+MISC metadata.xml 410 BLAKE2B 3fea63363ce1c4ee052dc0ad97b6748f52b503e99f9ffcb4c8c192ad397f60e4daa5c0643c1a7daab6fd4cce870b8890e131cb4255ba2f0a7ed4d85729f0f0e7 SHA512 ed22228e307053402c22509231054575200c56d47ec3371262c2fb95a739a602403d125ee38f753f512d860178d6b33a17f8db6ce6e3b3fc8e594ff6e88151db
diff --git a/dev-python/Rx/Rx-3.2.0.ebuild b/dev-python/Rx/Rx-3.2.0.ebuild
new file mode 100644
index 000000000000..d7dc1233b7a3
--- /dev/null
+++ b/dev-python/Rx/Rx-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY-${PV}"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="
+ https://github.com/ReactiveX/RxPY/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/dev-python/Rx/metadata.xml b/dev-python/Rx/metadata.xml
index 8f43c182b5fe..4c7cc2097fee 100644
--- a/dev-python/Rx/metadata.xml
+++ b/dev-python/Rx/metadata.xml
@@ -5,6 +5,9 @@
<email>blueness@gentoo.org</email>
<name>Anthony G. Basile</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
<upstream>
<remote-id type="pypi">Rx</remote-id>
</upstream>