summaryrefslogtreecommitdiff
path: root/dev-python/absl-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
commit9c572b23bc56215e9d24d375ddd293982c07dc08 (patch)
tree7db2215a276dccb1c70adc0dacf0eac994458517 /dev-python/absl-py
parentd498c2e6fb30b46f7db6e726a0edc1ba2b9d52b6 (diff)
gentoo auto-resync : 24:10:2023 - 08:38:03
Diffstat (limited to 'dev-python/absl-py')
-rw-r--r--dev-python/absl-py/Manifest2
-rw-r--r--dev-python/absl-py/absl-py-1.4.0.ebuild79
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/absl-py/Manifest b/dev-python/absl-py/Manifest
index ee6cf4d7a5c6..2510cb9749f2 100644
--- a/dev-python/absl-py/Manifest
+++ b/dev-python/absl-py/Manifest
@@ -1,5 +1,3 @@
-DIST abseil-py-1.4.0.gh.tar.gz 228096 BLAKE2B c34e6319d69976631a4b674d4f23eb0a11705c69fc1ce740eb2b570c61cc3507634d73699eb023b94fe6042c2f49eba3ec134c9c08958aca904eea3bfb8f84e7 SHA512 45cbf6f90a14a3d6e07ee0a6407d4521cac8d15340885c6ae790180c255dfea54e862ee2d806c166a28b5ce238720a7e3af25d6ffe054820588d4a0f20e1f124
DIST abseil-py-2.0.0.gh.tar.gz 232404 BLAKE2B fc3d02b2184f6ad45ff022d80068f6ec64ec4cbdbfb9735da1309a975f634880a2c969cba9ad7bdbeec2183c058c31e8198f9396d5f937858861e42a41c40432 SHA512 1f83ee07ce4bdeed2ebc775bdf809a9998f7afba2e0322bb4ce1fbf4af8c0e638161bbd72c9222c1ae1505577c181026d5baee1c9994d4858166d015a1ffab91
-EBUILD absl-py-1.4.0.ebuild 2536 BLAKE2B 6c48ca30e06c8c4085176a3f17065bf21b2cd0aac40c388f91a97218eb35525824c82279545b71c75d5698846172960e9aa92e3230c60d92e6e23d1f7667f47a SHA512 a66979017c21dfd0811e80eed31310a6af7d446792f171c127e477fb64edfb446d567f8404903036c0329caedc29f21aa4d97ecd65f5cca15ea53e09255b65d7
EBUILD absl-py-2.0.0.ebuild 2658 BLAKE2B 86b110e636334a69097b3674d5411c4071063c805ed8a137e8d78bdaf4f136ef417eac509f1371bd5c177108c13a57613d65288c701399feda322df268bc21ba SHA512 2b2f5dfbda899fbadec8da3ddb8eadd0102a1384a35a4df7164f91b60c1d41352a47edaac71977341e8b1d0bc6032f63e99d373d7f9b9d67f19c0224cdc6b407
MISC metadata.xml 577 BLAKE2B dd0e02b24bdb42f24bd675cadf13e99f861a6dc9be2879f671b9bc4e9e078ef81759909e81e3063cb54c71ff71d6609624f0cf2645bf6ec055c643fbb0f3ab5c SHA512 7cfa86cac5d38b10aedacdb4bafc7acbd11cf4a98a873a2435ef5761d5186c5128171eb286b2d2568a1a353eb4de815303eae225cf5823a5292ac362633b67c7
diff --git a/dev-python/absl-py/absl-py-1.4.0.ebuild b/dev-python/absl-py/absl-py-1.4.0.ebuild
deleted file mode 100644
index c7c5c3511cff..000000000000
--- a/dev-python/absl-py/absl-py-1.4.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=abseil-py-${PV}
-DESCRIPTION="Abseil Python Common Libraries"
-HOMEPAGE="
- https://github.com/abseil/abseil-py/
- https://pypi.org/project/absl-py/
-"
-SRC_URI="
- https://github.com/abseil/abseil-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- # what a nightmare... well, we could have called bazel but that would
- # even worse
- local helpers=(
- absl/flags/tests/argparse_flags_test_helper.py:absl/flags/tests/argparse_flags_test_helper
- absl/logging/tests/logging_functional_test_helper.py:absl/logging/tests/logging_functional_test_helper
- absl/testing/tests/absltest_fail_fast_test_helper.py:absl/testing/tests/absltest_fail_fast_test_helper
- absl/testing/tests/absltest_filtering_test_helper.py:absl/testing/tests/absltest_filtering_test_helper
- absl/testing/tests/absltest_randomization_testcase.py:absl/testing/tests/absltest_randomization_testcase
- absl/testing/tests/absltest_sharding_test_helper.py:absl/testing/tests/absltest_sharding_test_helper
- absl/testing/tests/absltest_test_helper.py:absl/testing/tests/absltest_test_helper
- absl/testing/tests/xml_reporter_helper_test.py:absl/testing/tests/xml_reporter_helper_test
- absl/tests/app_test_helper.py:absl/tests/app_test_helper_pure_python
- )
-
- local x
- for x in "${helpers[@]}"; do
- local script=${x%:*}
- local sym=${x#*:}
- sed -i -e "1i#!/usr/bin/env python" "${script}" || die
- chmod +x "${script}" || die
- ln -s "${script##*/}" "${sym}" || die
- done
-
- # i don't wanna know how these pass for upstream with wrong helper names
- sed -i -e 's:\(app_test_helper\)\.py:\1_pure_python:' \
- absl/tests/app_test.py || die
- sed -i -e 's:\(logging_functional_test_helper\)\.py:\1:' \
- absl/logging/tests/logging_functional_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTHONPATH=.
- local fails=0
- while read -r -d '' x; do
- ebegin "${x}"
- "${EPYTHON}" "${x}"
- eend ${?} || : "$(( fails += 1 ))"
- done < <(find -name '*_test.py' -print0)
-
- [[ ${fails} -ne 0 ]] && die "${fails} tests failed on ${EPYTHON}"
-
- # we actually need to clean this up manually before running the test
- # suite again...
- chmod -R u+rwX "${T}"/absl_testing || die
- rm -rf "${T}"/absl_testing || die
-}