summaryrefslogtreecommitdiff
path: root/dev-python/aesara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/aesara
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest2
-rw-r--r--dev-python/aesara/aesara-2.0.2.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 1671756c1f93..1afaa18437f1 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,3 +1,5 @@
DIST aesara-rel-2.0.1.tar.gz 7975083 BLAKE2B 6dfeffb5abbd2a9b8097b9f91b537f215b1d2ee8ec9d2ad2abcb823761b722c2e4de75843c74584445c96add175366ac4e2a62eced88ad75c58d0c31f2b4df87 SHA512 8dad298ada2d4a20151cf86c08424b02e1c0afc5060915844ba06a492866b04225e6cb0407bf1de8d651c0e7ed8bca34e184f2f9a2778a66ed41f08d4b51bfd2
+DIST aesara-rel-2.0.2.tar.gz 7974102 BLAKE2B 53ddfada4304776694553d491e80a8b20cec5b5b46819adcc099a7b4cf32dfc68b46d83ba7b769f22f0d088a42e8de269c3385aed4e185920a37c4a349b4a1d5 SHA512 f8f34a1750b5ad250e9243fc0d47f19cd0f8847650e98ea3cef6da03d5a50b884d03e7b6f5cab36d65948a6dd904742a851ac8ea475a0113eb9cbe230a5c834d
EBUILD aesara-2.0.1-r1.ebuild 1904 BLAKE2B 5826aa94aa158fde2fa8690f9a28ae1f676fc081d92bcf4134e566678292eddc6d40fa6694cff63be219dc7476be67b20cf42d2f483e561b5ca39b8342de7067 SHA512 9885c85d1756870c19c22e88ff0c1628c7e6773561bedeef2aa2fcce42055e7d5a8031bb7b2fd455fdc4352a6d1663526caab324f63a3a7b9d505790b60c0971
+EBUILD aesara-2.0.2.ebuild 1904 BLAKE2B 5826aa94aa158fde2fa8690f9a28ae1f676fc081d92bcf4134e566678292eddc6d40fa6694cff63be219dc7476be67b20cf42d2f483e561b5ca39b8342de7067 SHA512 9885c85d1756870c19c22e88ff0c1628c7e6773561bedeef2aa2fcce42055e7d5a8031bb7b2fd455fdc4352a6d1663526caab324f63a3a7b9d505790b60c0971
MISC metadata.xml 402 BLAKE2B a82c76dff3cfcbf83936f2815e15d051d4ab26a739a970848573f5856610e763d9f346e2d265b2d38e53460df6bcba879ce50d6e60bffea77af6052d03d8dc5d SHA512 f3c86b74cbaaadb63bb98ffc2a3e6e1d121c141b33edd574cfdee3652a43e9f8b05e3276050bd407f00ddbec1d6fb6eda87983520075ad368ab8792e0ae17143
diff --git a/dev-python/aesara/aesara-2.0.2.ebuild b/dev-python/aesara/aesara-2.0.2.ebuild
new file mode 100644
index 000000000000..e637143ab45e
--- /dev/null
+++ b/dev-python/aesara/aesara-2.0.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/pymc-devs/aesara"
+SRC_URI="https://github.com/pymc-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+ )
+
+ distutils_install_for_testing --via-root
+ pytest -vv ${exclude[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}