summaryrefslogtreecommitdiff
path: root/dev-python/aesara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
commitccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (patch)
treeff02c95ae3d9a1e73e2a182e268161743d81a88b /dev-python/aesara
parent74e526c590f52d24a213e25f77858ae0b34ec2c8 (diff)
gentoo auto-resync : 18:06:2024 - 00:10:02
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest5
-rw-r--r--dev-python/aesara/aesara-2.9.3.ebuild108
-rw-r--r--dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch46
-rw-r--r--dev-python/aesara/files/aesara-2.8.10-fix-tuple.patch19
-rw-r--r--dev-python/aesara/metadata.xml17
5 files changed, 0 insertions, 195 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
deleted file mode 100644
index ee5b48d44293..000000000000
--- a/dev-python/aesara/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX aesara-2.6.5-compiledir-tid.patch 1707 BLAKE2B 77f8fa3618f930dddad8e864dee3e73fc0b965018d508be5877d5bcae4430024c4e4f90e905ac912da22a4d4934d6fc71acf4ebd49b7e8efb12c90dfaa072ed2 SHA512 9b6bbd8bc56f61c89dfd85cb18251ff8d73d717d91178efa9309e6b897dbda28937dea84f1d7d1a917c285219d51c0adcee1233112f2dcdb9f8c7b714a6c6c12
-AUX aesara-2.8.10-fix-tuple.patch 649 BLAKE2B bfc2b2971fdaa452c5d14d75f68af5931b979dcb2951baf8bb1cf759058b4c0f341233b33d907722302ea8374cbd965e4d09e87f069ee2b1a558bf4e9a7309c9 SHA512 2c5846c723f214a8f623593f518194edb113f0d7c64ab1d69d6e4c5278125910f1c775cffdb46871d23ddf5332bbd84f252ed58e2560663c0c36520f1fb72372
-DIST aesara-2.9.3.tar.gz 4424476 BLAKE2B 3b1a1f2644267171a04a73d09a20fa29e0cf1eae3a86f5ee9ab72084185080b94cd1855fe8957b5f08aac4d059b047839524218526df37ea711bc3a8871c7e98 SHA512 28a6aedc7e6095a9a4e96eeac453282a0d6e247bd01248c219a5c161bc52ce4ccfb998238b45120b92581d1d0168c87c472aa0a8bb3314d8eb7ce90868e045b5
-EBUILD aesara-2.9.3.ebuild 3385 BLAKE2B 4afbbed17e300ee5f063d52bad3f2ac99903fac3a455c31ea605afc678fe06d9b27a5f1c9c6e70742b38ca05ddb098720920b8071571c943adec22f1913727df SHA512 ee600ae4d0ae2464751be68c358d003890e5d4bbd622e3e1c873a87181251380a93c7bdb4635ce7aba6bc878450a2c879c5f6d866a7e62471eb7b6c326c436d8
-MISC metadata.xml 506 BLAKE2B be65b6be62282fa47152985d79892fd04105a47e00a427ee8341d27aeff21b144bee7e7d0f16b2f4b617c941bdf5ebd9de37a42c39d117cdfd579c3035d35a74 SHA512 a207ec3db85a8e6f03feabd14da588f0b9ca9a88ab2495ade0f40b516b3bbd20fe78b14698d28da7ceed238737a9f4d63f587156ef609e846b485132d598c6bb
diff --git a/dev-python/aesara/aesara-2.9.3.ebuild b/dev-python/aesara/aesara-2.9.3.ebuild
deleted file mode 100644
index 614a4de0bfab..000000000000
--- a/dev-python/aesara/aesara-2.9.3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing optfeature pypi
-
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
- "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # Deprecation warning causes unexpected additional output
- tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
- tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
-
- # TODO: Package pytest-benchmark
- tests/scan/test_basic.py::TestExamples::test_reordering
- tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
- tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
- tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
- tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
- tests/scan/test_basic.py::test_cython_performance
-
- # new numpy?
- tests/tensor/nnet/test_blocksparse.py::TestBlockSparseGemvAndOuter
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}
diff --git a/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch b/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch
deleted file mode 100644
index aa36fc26fb12..000000000000
--- a/dev-python/aesara/files/aesara-2.6.5-compiledir-tid.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 6e49c314cd5050763f983759d156f26ffbc59368 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 7 May 2022 23:38:31 +0200
-Subject: [PATCH] Allow referencing thread identifier in `compiledir_format`
-
-Add a new `thread_id` key that permits referencing the current thread ID
-(`threading.get_ident()`) in `compiledir_format`. This makes it
-possible to use per-thread compiledirs in multithreaded programs,
-and therefore make it possible for aesara to run multiple compiler
-instances in parallel.
-
-Combined with pytest-xdist, this change makes it possible to run
-aesara's tests in parallel and better utilize multiprocessor (multicore)
-systems. On my Ryzen 5, this provides around 4x speedup (down from 82
-minutes to 20 minutes per test run). Given that we are running the test
-suite multiple times to test different Python versions, this literally
-saves hours at a time.
-
-Prior to this change, xdist would not be able to fully utilize
-the available resources since the compiledir lock would prevent aesara
-from starting multiple compiler instances in parallel, and therefore
-practically serialize tests on compiler invocations.
----
- aesara/configdefaults.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/aesara/configdefaults.py b/aesara/configdefaults.py
-index 8121919958..60eb4f997e 100644
---- a/aesara/configdefaults.py
-+++ b/aesara/configdefaults.py
-@@ -7,6 +7,7 @@
- import socket
- import sys
- import textwrap
-+import threading
-
- import numpy as np
-
-@@ -1345,6 +1346,7 @@ def _get_home_dir():
- "numpy_version": np.__version__,
- "gxx_version": "xxx",
- "hostname": socket.gethostname(),
-+ "thread_id": threading.get_ident(),
- }
-
-
diff --git a/dev-python/aesara/files/aesara-2.8.10-fix-tuple.patch b/dev-python/aesara/files/aesara-2.8.10-fix-tuple.patch
deleted file mode 100644
index 7eb537d54286..000000000000
--- a/dev-python/aesara/files/aesara-2.8.10-fix-tuple.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/aesara/tensor/nnet/corr.py b/aesara/tensor/nnet/corr.py
-index e89054d..77ed344 100644
---- a/aesara/tensor/nnet/corr.py
-+++ b/aesara/tensor/nnet/corr.py
-@@ -692,12 +692,12 @@ class CorrMM(BaseCorrMM):
- if kern.type.ndim != 4:
- raise TypeError("kern must be 4D tensor")
-
-- out_shape = tuple(
-+ out_shape = tuple([
- 1 if img.type.shape[0] == 1 else None,
- 1 if kern.type.shape[0] == 1 else None,
- None,
- None,
-- )
-+ ])
- dtype = img.type.dtype
- return Apply(self, [img, kern], [TensorType(dtype, shape=out_shape)()])
-
diff --git a/dev-python/aesara/metadata.xml b/dev-python/aesara/metadata.xml
deleted file mode 100644
index 010f78c68d85..000000000000
--- a/dev-python/aesara/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">aesara</remote-id>
- <remote-id type="github">aesara-devs/aesara</remote-id>
- </upstream>
-</pkgmetadata>