summaryrefslogtreecommitdiff
path: root/dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild')
-rw-r--r--dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild b/dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..e0e943e117c8
--- /dev/null
+++ b/dev-python/agate-dbf/agate-dbf-0.2.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds read support for DBF files to agate"
+HOMEPAGE="
+ https://github.com/wireservice/agate-dbf/
+ https://pypi.org/project/agate-dbf/
+"
+SRC_URI="
+ https://github.com/wireservice/agate-dbf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/agate-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/dbfread-2.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest