summaryrefslogtreecommitdiff
path: root/dev-python/agate/agate-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
commitf29a41111b3a606f5d95049b1ba92daabbc68cc0 (patch)
tree310589df1ffb427b1a0595a329cfb2845335b778 /dev-python/agate/agate-1.7.1.ebuild
parent083bdfbef9bc532b72cf116591025916eebaf676 (diff)
gentoo auto-resync : 05:01:2023 - 12:08:57
Diffstat (limited to 'dev-python/agate/agate-1.7.1.ebuild')
-rw-r--r--dev-python/agate/agate-1.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/agate/agate-1.7.1.ebuild b/dev-python/agate/agate-1.7.1.ebuild
new file mode 100644
index 000000000000..e26f80c167cc
--- /dev/null
+++ b/dev-python/agate/agate-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)