summaryrefslogtreecommitdiff
path: root/dev-python/aiocache/aiocache-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/aiocache/aiocache-0.12.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/aiocache/aiocache-0.12.0.ebuild')
-rw-r--r--dev-python/aiocache/aiocache-0.12.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/aiocache/aiocache-0.12.0.ebuild b/dev-python/aiocache/aiocache-0.12.0.ebuild
new file mode 100644
index 000000000000..ac1baf19bf02
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="https://github.com/aio-libs/aiocache/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# TODO add optional cache systems deps (and new package aiomcache)
+# Tests require all backends
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-fix-test-installation.patch" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}