summaryrefslogtreecommitdiff
path: root/dev-python/aiohappyeyeballs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-05 01:46:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-05 01:46:50 +0000
commit77d1bb6f8d47023aa21aaee830bf3229837233d1 (patch)
tree751b6c0d12ed0ed73cc1e3fbca7404072ba6cc7a /dev-python/aiohappyeyeballs
parentd13006cca857323814c09f5123b87c1a005bba74 (diff)
gentoo auto-resync : 05:03:2025 - 01:46:50
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest2
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.8.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index bf602cb50d70..21f61cc17e1d 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1,3 +1,5 @@
DIST aiohappyeyeballs-2.4.6.gh.tar.gz 72830 BLAKE2B aea6f5e20a2900fb5d498722edc5e1b776552ff4ca84120f2e1acea5478a571ab923d3bca4c58111f5ff0389ddb7f4976f6231b575b7b282e3c45e4adebb9707 SHA512 0098f13604c929998981deaa9ae221f0c5c4c4de46e5063b23e185e1437637b35256ebc91a3f7fdf6b5f9dee6f4be5ff3c215a8ddd34a02a0389c9b49c329c16
+DIST aiohappyeyeballs-2.4.8.gh.tar.gz 73672 BLAKE2B 9f2268f077106007607b3e463b9c86d7264ffb14ac3d27d07a29e919194dc1ba0210cd8d53b25fc2476794cbfa2f5e4cc400d405dc9bef7b3d61a764d5ed28da SHA512 081eb29d6be252170822d86d3de8e15165e461969788d539a20e796dfa34204f4d04e69380873a038e44c87194c61fd394a3bd105102c593a7aa17a4c2c3bd66
EBUILD aiohappyeyeballs-2.4.6.ebuild 786 BLAKE2B cf363479070b9093bb3497540aca795da19684609b79da66f8fc601a185e3bd9fe46841303601cd15158b07e6f41910e30163c8f324835b1242de04b7592bb06 SHA512 9fbb699889ca7bf537d7c97f461587ec27ee6c6257bc9a79e5dcf26ff194280329994232da45cf54ad87cdcc0ec736c1776077e1cb38549ec3f33ac069eb8d42
+EBUILD aiohappyeyeballs-2.4.8.ebuild 794 BLAKE2B c1454e9d3ea2849716f37a79540070e9c2720372e6c6107ba41ea925876eaf6b8ed080ae149f89075be5f6cf840ab73d0f3f87864772463d951aaf66b5f06625 SHA512 66502f75554fcd347daca0709ac4dcd883a64e4cbe3d5e8c24dd2b1fd1a3a152bb514ce988366c76b7cb85ba525c8878d1633b1da97482b8b36ccee06f0c7ae8
MISC metadata.xml 387 BLAKE2B c739dc88d077c51dae10eb7aaa84091c6c7904a782ee3eabb12b6167c7e4ae8528b6464612f891eef5f12add728caa66fd30cd93c3b13e022cedae267c1e9f40 SHA512 65973b766dbcbd20b8c25e8e76c4d662bf5478d6c860f8cfd460be8795fbd141c58fed586a678506360af8ac013ec4c2292cc2e1092a5bbd8a3c54160adadb94
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.8.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.8.ebuild
new file mode 100644
index 000000000000..47f81490d8cc
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}