summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-cors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/aiohttp-cors
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest4
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild37
-rw-r--r--dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_7.patch23
-rw-r--r--dev-python/aiohttp-cors/metadata.xml9
4 files changed, 71 insertions, 2 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index 9aeb312d2dba..0c7389160e78 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1,4 +1,6 @@
+AUX aiohttp-cors-0.7.0-py3_7.patch 991 BLAKE2B e2a08dab701bd31e4a9008c8f89ae97508fb6b99b89db69a05b731849e09c6f04e8b148d82d38f2093e00bb9bee03e45f230cfc8eff4b71ca7797a95524732e2 SHA512 efe7c488d9f30da7eebbe355d86c603657bddc75c88f5cd1bb4b0e76b17f26f5827cc2f42ab8766767a4ad16c08fa636a4f61e50a8c478e7f32eb2567e26427c
AUX aiohttp-cors-0.7.0-tests.patch 2422 BLAKE2B 4660be793987dd0cd5c945703aa4d6d4b499ba0ab1c305b80e26bac9cc87d811131f6ab179e402821740f193bbfc86a384b58e35aaa453fdfd5d4db3bcc44b23 SHA512 b3fa463b87a112529443f516fe1c37ffda092e8a0133a6d37f407519e32842f65773c87e939082591edb969ee243170be3a4828896ec5ffc1150c3f43aedd9d5
DIST aiohttp-cors-0.7.0.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
+EBUILD aiohttp-cors-0.7.0-r1.ebuild 914 BLAKE2B 520d9cb0dfa19ae110ef27d753469d767c3e890622de19d656ebff98d16ae157db3d1161fec22a6719162261722c26884870cd0cf365af35b81fd349f527a03f SHA512 941925c42e5df8ef78996879feefe1e916ee636032bc56c8a2c886f2ef60d46334619b815c491d0908829deda4e0d924e5ec8032eb410281eb844e50c8c6d0a2
EBUILD aiohttp-cors-0.7.0.ebuild 842 BLAKE2B 4bbb7534da92f7c7cec32437581e0aaf0670d654319d81271cf5cb6d296928b05538958ab6f96d055bbb457cc5e218b8e4fe40645a67d4b1161ea2f771ef650f SHA512 dd3e95e9ff72ae87c0e1ea6bb4e161d1960553589b7a30ae2b9750d5bf9ae38f3e223181580a75220c36249929119dd54453a78fb7f061cc9bf90d21f773538b
-MISC metadata.xml 253 BLAKE2B 0311910d10e4b501d39c01678bb1e58bed2e6e3252e6c3195d3284cf2e9652081b10a83f045689a56c69a4d318b209bfdac0a63ff6dab2a8fbb0160ac9c7e2e2 SHA512 bf75301ff2098e846a7d6dc9166d1c8b6e77b4f92327e5c5aad0edcde6274e6aa224d89c2c5ed7efc6fb7fcc7258a2a01a24591a43688679c4109f8cc89fd9b1
+MISC metadata.xml 453 BLAKE2B 425da23ceef20765f00fd1f15b34bf99166f66dc7d6cdc0ee74a7d6439ed912ebf79c365daf9cb50a918802706aa8782d88cee3520b1e37bf3e6505579521263 SHA512 690dfd58364f19eb58ae3348b9b2a8d64fdf4324dd26fb63cf563762f4f8368437fbae1afeeffeb0ccaeac100d793008e28b66309139e27418ef5cd70daf0d8c
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..eded3a043888
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+# https://github.com/aio-libs/aiohttp-cors/pull/278
+PATCHES=(
+ "${FILESDIR}/${P}-tests.patch"
+ "${FILESDIR}/${P}-py3_7.patch"
+)
+
+src_prepare() {
+ sed -i -e '/^addopts=/d' setup.cfg || die
+ echo " ignore::DeprecationWarning" >> pytest.ini
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_7.patch b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_7.patch
new file mode 100644
index 000000000000..9a4610824099
--- /dev/null
+++ b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_7.patch
@@ -0,0 +1,23 @@
+From e64b95848f3253157d831f4934841fceeaf9b2e3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Thu, 14 Nov 2019 12:54:47 +0100
+Subject: [PATCH] Test instance type by isinstance, not issubclass
+
+https://github.com/aio-libs/aiohttp-cors/pull/278
+Fixes https://github.com/aio-libs/aiohttp-cors/issues/277
+---
+ tests/unit/test_cors_config.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/unit/test_cors_config.py b/tests/unit/test_cors_config.py
+index 817410e..d494e20 100644
+--- a/tests/unit/test_cors_config.py
++++ b/tests/unit/test_cors_config.py
+@@ -103,7 +103,7 @@ def test_static_resource(app, cors):
+ "/file", "/", name="dynamic_named_route")
+ assert len(app.router.keys()) == 1
+ for resource in list(app.router.resources()):
+- if issubclass(resource, web.StaticResource):
++ if isinstance(resource, web.StaticResource):
+ cors.add(resource)
+ assert len(app.router.keys()) == 1
diff --git a/dev-python/aiohttp-cors/metadata.xml b/dev-python/aiohttp-cors/metadata.xml
index 90e51cd48781..a00e54b3e81f 100644
--- a/dev-python/aiohttp-cors/metadata.xml
+++ b/dev-python/aiohttp-cors/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>onigino@protonmail.com</email>
+ <name>Gino McCarty</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">aio-libs/aiohttp-cors</remote-id>
</upstream>