summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-jinja2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aiohttp-jinja2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aiohttp-jinja2')
-rw-r--r--dev-python/aiohttp-jinja2/Manifest3
-rw-r--r--dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild51
-rw-r--r--dev-python/aiohttp-jinja2/metadata.xml12
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/aiohttp-jinja2/Manifest b/dev-python/aiohttp-jinja2/Manifest
new file mode 100644
index 000000000000..7fec1f646610
--- /dev/null
+++ b/dev-python/aiohttp-jinja2/Manifest
@@ -0,0 +1,3 @@
+DIST aiohttp-jinja2-0.15.0.tar.gz 51183 BLAKE2B e19ca813f36ac746a84812ec278a3de43e6e24eaafcf949fd18a32c99f460ded03f4dc97171fe1493174a8e2c51543b8c1afcdec51c4688f4fb0b7781287cc03 SHA512 084714cd2376b93f32cdcebc1971d4aaa704a177524b00f322e0347c15ab8085960a68a3760be056e391410f01b6b637eb59db54fccf54d09ba53a9ea03a01db
+EBUILD aiohttp-jinja2-0.15.0.ebuild 1128 BLAKE2B f0ba27b253c30de124f5e25e8371d3a1471d52998756b2f12db1caa61df0dbf0d6ac993a85f09518db84d61f75433e46fb64b13eb3c73b7b350ec7bda9f631aa SHA512 18ac2ac37ce85b95a25ac06e3cfefc8a2cd808580d49073154592f7740ca45518b3a5ec12070218535f56d0107af501ed829ab9b5b7d8558d6859683b1ca9366
+MISC metadata.xml 384 BLAKE2B 37044e46bf0ffa1925c6b50e3d2298993ecc3c8f42e18c52bfec22b620dafcabc77cb63f51f98337470f0edeb600c6b96c0b518f012bcfd3147a0f91def9d30f SHA512 fa82c2fd1f793d00baf665208c6321db03f037782c592f84d5efef68c271413ec080cd0322fc308cb4eddbb3e8667b907036eaf4cf8e00a800b9657bd9b366e1
diff --git a/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild b/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild
new file mode 100644
index 000000000000..9e58af359e8c
--- /dev/null
+++ b/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="jinja2 template renderer for aiohttp.web"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-jinja2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/aiohttp-2.3.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-3.2.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-aiohttp-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-capturelog-0.7[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES.txt README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/aiohttp-jinja2/metadata.xml b/dev-python/aiohttp-jinja2/metadata.xml
new file mode 100644
index 000000000000..d312e97052bd
--- /dev/null
+++ b/dev-python/aiohttp-jinja2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aiohttp_jinja2</remote-id>
+ <remote-id type="github">aio-libs/aiohttp-jinja2</remote-id>
+ </upstream>
+</pkgmetadata>