summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
commitd36c5f9e59f92a021c987989cd79d44460e0da42 (patch)
tree2504c88d1f287ac3a71ebc56e5d19f34a2c1b9a4 /dev-python/aiorpcX
parente860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (diff)
gentoo auto-resync : 31:01:2023 - 21:02:55
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index d0f2580d5b67..f9dcbabc3793 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -1,5 +1,6 @@
DIST aiorpcX-0.19.1.gh.tar.gz 72903 BLAKE2B ba3da1bc1f8d83ec6c6d2189aee554b4b819b601d366d0e8858ec73fe6aedddf6a6ed00d56d66c38d18ee44921a4cce7cb83ebf05aec9348355f88b8ed67e1a5 SHA512 b71edf335ad78b1d46b2b23dcb102b29f988d32f75571b881e2ce3471bf48c7ffc9bf509ce1cafec036662bb06d6f90598304c207f416b4124a7b02fdca915e8
DIST aiorpcX-0.22.1.gh.tar.gz 75206 BLAKE2B 92c481388198fec94faa10482ad4195fe6dce5ae4aa445ce2812e1e81e084c629712b87a3c157aa33ae42335c1a96bdcafa5e389802740fcae8eb9e4aaf43dd2 SHA512 3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d
EBUILD aiorpcX-0.19.1.ebuild 862 BLAKE2B 15568116c38fd344c7a7a41250b0254425193f774bfd7e96792c91bd9e0b87c7999955844e2a9d76d81c40a81c01b7f5930d0ad00756d1c6b212c0767f97cf8b SHA512 ba79792d582f1575bd1a8bde7aee13c03aa9a577f90614353cefb51d7d8f1878af2dd3ce2b5d7c8cc18bf392493b88393364d85f0239536cdf7829d9b394efeb
+EBUILD aiorpcX-0.22.1-r1.ebuild 806 BLAKE2B 78b4fe721786295eb7e7eaa6f7b3d56134552a84f08b9476b8de37ca7fceb562bf79a141ae1fa0dabf413c39191e1bca3aa9b2e1ca3ba3c9af45df6d2082827f SHA512 66f33c4cee654439e9b3e5905f236adecfeff9af7e0d176a54419057d6d2a3d69dad41b829dde35ae13b303ac7b45d876547f3b0f07c54d75c71c395bcd849c7
EBUILD aiorpcX-0.22.1.ebuild 824 BLAKE2B 613b2414fc164e5b86a8ab6bc471435bd9d1eb53e3298a68d9d33156790548be6fe8cf13a5e176a90353a486081d774b468ebda9c17299eafbba0d93c8df60fa SHA512 7f234f2357764079456f0a23870ab6128bce9dbc8e87f05eae70ee0977582a7652f67213c99d5d835ae7d0527132272616fd49b7b9e0b033c9776f5e92dc3c73
MISC metadata.xml 406 BLAKE2B 9b7f11edc470d0fe068819de2612c0505b69da7974aaa85f42f41449d33e5b3f05105c8a2419a0be96afcce6356ed483a4274bb4795531c58d30603f042e23c1 SHA512 fe0980b5d6bf46d30af528c298d6aa20bdcf49914c01e35542dcc5ddb935e3bb1ed367ce7fe9fda6bf2c348aad8c2d6158ba0f270b320f9af443a8e14ecb30a8
diff --git a/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
new file mode 100644
index 000000000000..478599928eee
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="
+ https://github.com/kyuupichan/aiorpcX/
+ https://pypi.org/project/aiorpcX/
+"
+SRC_URI="
+ https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+)