summaryrefslogtreecommitdiff
path: root/dev-python/aiostream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-09 15:18:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-09 15:18:13 +0000
commitf3104c28cf5ceeea12dea8aab516861d975c817d (patch)
tree0f4946a9ed67aff71917cd2dcd45cfb7d80f8eb1 /dev-python/aiostream
parent1f9ba344a5e235c6a8667384aa6ec8dd42d73889 (diff)
gentoo auto-resync : 09:12:2022 - 15:18:12
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest3
-rw-r--r--dev-python/aiostream/aiostream-0.4.5.ebuild37
-rw-r--r--dev-python/aiostream/metadata.xml13
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
new file mode 100644
index 000000000000..f32e15e7b22d
--- /dev/null
+++ b/dev-python/aiostream/Manifest
@@ -0,0 +1,3 @@
+DIST aiostream-0.4.5.gh.tar.gz 39797 BLAKE2B 5aeb4da46158d949190af22133f1798831e14f8d8da231d3dc098caaace303061bfa49dfef1d52c533ce20201937bf5da33f36806634b2e73ccbc48c00962486 SHA512 ac1a67a6d27e18e290c5ae5b069de2e7f7205120bc747885261e23155019d5630c1f7b643df3a4fef12844d52cdfc0f1fcdcf5cb35a0061000d426c62dcffb1d
+EBUILD aiostream-0.4.5.ebuild 736 BLAKE2B a464b36ba1231fb50b8e4636f9e1b86df2b3a7305308ef4134b7246376972b53b01c2a9ecd9abc90cc8fb6fb3212b90e86b932fa8c8672e876f32608bd218c15 SHA512 7b88f1bb25eceee7a0da63f523af532e6e190b029b6d18b354fac0350521218fe71edebd06aed762db4ee36a66846ebff373de0992ed4195aa2bf4a1b5bcd0c2
+MISC metadata.xml 396 BLAKE2B bc8d636bd40d6291341e397900882cd9791c17a3f6511740f05cd67c8fa117a1b04d5ff90ddfada0ed66dd10e72a06c4cae01ce9f5d0c005ea83509bbce264c3 SHA512 fcb085c0707495790bb7b2862b1a41e9cacdde2b06a382209f7e1e451796da4acef27761d3f32be9f9aedb95690ee26e52e93b00b963ae3fcf87441df2e90e69
diff --git a/dev-python/aiostream/aiostream-0.4.5.ebuild b/dev-python/aiostream/aiostream-0.4.5.ebuild
new file mode 100644
index 000000000000..7e0a5fb73136
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.4.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream --cov-report html --cov-report term::' \
+ setup.cfg || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/aiostream/metadata.xml b/dev-python/aiostream/metadata.xml
new file mode 100644
index 000000000000..b33e8982719d
--- /dev/null
+++ b/dev-python/aiostream/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">vxgmichel/aiostream</remote-id>
+ <remote-id type="pypi">aiostream</remote-id>
+ </upstream>
+</pkgmetadata>