summaryrefslogtreecommitdiff
path: root/dev-python/alembic/alembic-1.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-08 10:30:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-08 10:30:27 +0100
commit2c1bdf9e63a9a82efe90cc9d82696812db076f7f (patch)
treed601077f80eb4e5b35ec09917804b1a153f1b894 /dev-python/alembic/alembic-1.11.1.ebuild
parent91123d2faefa2e7d77657215ec9287ae5d6dc0d7 (diff)
gentoo auto-resync : 08:09:2023 - 10:30:27
Diffstat (limited to 'dev-python/alembic/alembic-1.11.1.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.11.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/alembic/alembic-1.11.1.ebuild b/dev-python/alembic/alembic-1.11.1.ebuild
deleted file mode 100644
index 5e88fa80c9a4..000000000000
--- a/dev-python/alembic/alembic-1.11.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
-HOMEPAGE="
- https://github.com/sqlalchemy/alembic/
- https://pypi.org/project/alembic/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-IUSE="doc"
-
-RDEPEND="
- >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # setup.cfg contains -p no:warnings in addopts which triggers
- # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
- epytest -o addopts=
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- distutils-r1_python_install_all
-}