summaryrefslogtreecommitdiff
path: root/dev-python/ansi2html/ansi2html-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /dev-python/ansi2html/ansi2html-1.8.0.ebuild
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'dev-python/ansi2html/ansi2html-1.8.0.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-1.8.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.8.0.ebuild b/dev-python/ansi2html/ansi2html-1.8.0.ebuild
deleted file mode 100644
index 5ec4a4804d68..000000000000
--- a/dev-python/ansi2html/ansi2html-1.8.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/
- https://github.com/pycontribs/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~riscv ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- doc? (
- app-text/asciidoc
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- use doc && doman man/${PN}.1
- distutils-r1_python_install_all
-}
-
-src_compile() {
- # Upstream https://github.com/pycontribs/ansi2html/issues/124
- use doc && emake _MANUAL_VERSION="${PV}" man/ansi2html.1
- distutils-r1_src_compile
-}