summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
commit941687623283212199cbe6e36f7d61b89d6222b2 (patch)
treeba7fb5198fd46b0b501a9c4362be2c26738408ad /dev-python/ansible-compat
parent44cec61076bf2bbb3cea1fc89943dd6818a5acc5 (diff)
gentoo auto-resync : 07:06:2024 - 00:08:01
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-24.6.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 560294083136..cb16718568a9 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,5 +1,7 @@
DIST ansible-compat-24.6.0.gh.tar.gz 74286 BLAKE2B e61b9501aad867e738d128397f4b37e1299f4bc249e4217def60a704dd470886d269b2b61b738a644300085c4d46793bd32982c470de7a26590990c14eab4810 SHA512 217faed3354e459d9541962778f455b34b4ddf1c9b8141752645b25fd68747305de5d08d65b01c8168907e70c1dc31aeb2099420bf1e3553cd7f41627a12f0da
+DIST ansible-compat-24.6.1.gh.tar.gz 74317 BLAKE2B d79471cfb150720bec8daa037df400005184b023ad55389c3424db55c2be87f57dd22934d133fc76b97e15ee3f80d78d1865c7feef0168793efa9b5738bff85e SHA512 203dd95dac7f55f21ebda069fd3e460f09a5434805529843880efe7137a55ba9d9c4eca72074bba7786b2cf0d032cd4a9a63d78d6e4c36811ec818340dd96ce4
DIST ansible-compat-4.1.12.gh.tar.gz 67966 BLAKE2B 3c665eb2cb87e184042da78ed1c41e7ca2b437c5151ba21bdd609104b44fa28c5f03247d275c58cfdf04a8e9ed328947cb0c2670603218798e3a484861274af2 SHA512 c9b2c340dc2b1ffb6f6db76017f7537e20307a7519a4df2dfb31811180cd647e39812bc433db51bd94d42f4c52a6c2f729d81edadcd615a5e0d23566969d8911
EBUILD ansible-compat-24.6.0.ebuild 1819 BLAKE2B 45f593be905c5424d724e507998528cf9b194372c497270a3dfd0fa8fe3404a6c6d01fa7c928b1aeabdc08e0ac2d4053657ec2c7e46b3b7632300d80f74dab6b SHA512 0cf744412ffcd8ac2e7446cff02f00ca5a3c91194b2e601456b2a5941391dc36a7903224cd35a9ba1580012ad04f72764bb56375fbe30e061a42bd0396f28add
+EBUILD ansible-compat-24.6.1.ebuild 1819 BLAKE2B 45f593be905c5424d724e507998528cf9b194372c497270a3dfd0fa8fe3404a6c6d01fa7c928b1aeabdc08e0ac2d4053657ec2c7e46b3b7632300d80f74dab6b SHA512 0cf744412ffcd8ac2e7446cff02f00ca5a3c91194b2e601456b2a5941391dc36a7903224cd35a9ba1580012ad04f72764bb56375fbe30e061a42bd0396f28add
EBUILD ansible-compat-4.1.12.ebuild 1792 BLAKE2B c472941306908a0d28b2d09198e087d53ef0ac1e460ee9a4e296786932179cd9971d8b891d706e0d8632318e56db418fb621ccd2f6d3b71f6b90243a2dbf3315 SHA512 1c4e239690345a25a8dc291ec6694b87e6eb0fd0d3f8cc964c0688951b045a34c30fb370faf7d9777183234b61aa5abe75f38bd5ac303375b46ec09c2a4dd731
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-24.6.1.ebuild b/dev-python/ansible-compat/ansible-compat-24.6.1.ebuild
new file mode 100644
index 000000000000..18c39cfc27c2
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-24.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+# We normally use PyPI here but 4.1.12 has never been uploaded there for some reason
+SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.14[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+)
+
+distutils_enable_tests pytest