summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
commitd2e43b44e8855b7ee7b79782358dee45099efccc (patch)
treeb6dd4c6cf2a46f31df970692a4aed40056dff35e /dev-python/ansible-compat
parent1a256280f70812d1ae23f0ce2a2569291b6609da (diff)
gentoo auto-resync : 25:09:2022 - 11:33:33
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.2.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 8a72a4159ce4..d9e3acd1e336 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,5 +1,7 @@
DIST ansible-compat-2.1.0.tar.gz 37840 BLAKE2B 5ac74cdaef1c932094996f331ed94418836b3351cbd376ae35ef22046b68dad0a8ab68fd293015db9954e0a5e1df4b5c529b3845cee5778daed2bb207733ca4f SHA512 a85681aff3d34ef4a4cdad8f419017a174bf315034495bc032a7e33d586cbcf72de74d163b6faf3cd21988704e5dbb922872b83a23981891311dbb18e53797a3
DIST ansible-compat-2.2.0.tar.gz 38772 BLAKE2B dbe74d23d2f2e4275bd9df2303417ea83517e780e65c6a34bd6ae1022be265ac816b50b309fc45f88e0c7fac7d7a22c83a826cc15be050698a6f35b267a36ac3 SHA512 3bd199431659ecba52743c6c985d2cdc6ee55396444241ba2456bc5430bbc87e26087dffbfff62ac341fa854e19baa0d7052cf79f20511222fd9e001dd020136
+DIST ansible-compat-2.2.1.tar.gz 39126 BLAKE2B c4d0512606c99ba8f07e0287620c94af6b46d7bf0077f12dcbfd9689fc7106f164a87db25de1625249ac2930858bfa655bd93d83aba0d85ed4f8bdd42cd345dc SHA512 3e941eb2c5303f83b7e7c057d08801f192889b636d9c6e56a2ac21cf75144a52ba2916eaedeba7bf848dd268387bf4d3261541d75145b213cc3f6baca6a06e5e
EBUILD ansible-compat-2.1.0.ebuild 1801 BLAKE2B 631de4e8e8071eed1197c11e500cf4108e879a6e4912417d66bf793e8dce0a28af76a4da7666aac77631f869d0f0eeb763b399c81de0bd08171891b1c0e7df89 SHA512 36d1c856bacbecf6eda95f0f603269a716e9e29090a92cf4c10f6bbd38ab3a7d045258cb2cf7f1ba4dc31b25d03b64b45968817fefe402b4ff15344b71d72d19
EBUILD ansible-compat-2.2.0.ebuild 1841 BLAKE2B 904c48ad161c04d567bcbcda9595c9a477645fc2e142611227719e11a8df77aa5a2715bb8fdc1a01013941759baad984f923e49a66a0c831b046a9abab9c0cbe SHA512 7d77e77637814d7df743ca402e38a2815526dfc629e46653283d9f804cf688f699e13a06df2cf4c10b345ec9b5631aafbed9673d402315caa90f6a007ce69803
+EBUILD ansible-compat-2.2.1.ebuild 1841 BLAKE2B 904c48ad161c04d567bcbcda9595c9a477645fc2e142611227719e11a8df77aa5a2715bb8fdc1a01013941759baad984f923e49a66a0c831b046a9abab9c0cbe SHA512 7d77e77637814d7df743ca402e38a2815526dfc629e46653283d9f804cf688f699e13a06df2cf4c10b345ec9b5631aafbed9673d402315caa90f6a007ce69803
MISC metadata.xml 510 BLAKE2B 3f47270866cb9acc5944b71547640b69003891268ffc07b5cd10e6ba8842b6f644ab4dea3b3da2d20b17f34d90e565b6f03a4dbb8ea38fa282fed283ac22fac1 SHA512 65d8604e46581bf9ecb3d8e358f3a211b18c51beea22c92a1cd3668ba86140e3bd8d91a38c221e73fe13a3e0da1cbfc2030b3f7733ee55e045530b49cd77d46d
diff --git a/dev-python/ansible-compat/ansible-compat-2.2.1.ebuild b/dev-python/ansible-compat/ansible-compat-2.2.1.ebuild
new file mode 100644
index 000000000000..0a8b7add6886
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.2.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytest_markdown.plugin
+}