summaryrefslogtreecommitdiff
path: root/dev-python/ansible-pygments
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/ansible-pygments
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/ansible-pygments')
-rw-r--r--dev-python/ansible-pygments/Manifest4
-rw-r--r--dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild22
-rw-r--r--dev-python/ansible-pygments/metadata.xml7
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/ansible-pygments/Manifest b/dev-python/ansible-pygments/Manifest
index c7dcd361df32..fafc03707225 100644
--- a/dev-python/ansible-pygments/Manifest
+++ b/dev-python/ansible-pygments/Manifest
@@ -1,3 +1,5 @@
DIST ansible-pygments-0.1.0.tar.gz 8046 BLAKE2B a6b9873dc8494af77a8c71de45f23dbd14419f3abb98d577631d51be9fe48cc88f5bec2f77707fd376369e325538800a47ae014a13f85022f805466a2e590316 SHA512 370a28e984f1c19c78b3047c5506847d625ad46458067804fcc7cc850d01cb77f837fbc80071fc9ff0e9df31805e48477a3026ce28389de8de368d35bd9d9428
+DIST ansible-pygments-0.1.1.tar.gz 8446 BLAKE2B ff631dd24c723035db7ab11a6c3fc0c90e8cebd72e6b0fa0d8b2c4bc4250ff5fb1e4180366e4ee084aab90bf24a8c3b2ecfad2c421b9f0cfdbf7675c94f0fcf7 SHA512 1ad2f4568d46d7fc617c6e674bcd9aea48e14307d91c476b51a04f778b452f18cb983d87d4872664d567b984193edee2af7964854fb2f3ae37ab4bce09c387d4
EBUILD ansible-pygments-0.1.0.ebuild 514 BLAKE2B bd9363775c4e72c462fee45860eb269b838ff962b2ffb53f746a9d9e8d71695422a01e87b35e503ad328483ca8c597a3b86ed229c9f11be3365a06683ab08da6 SHA512 f8c0fab96f93c3154f592842a6e8321824b7c7013adb27dbc7937bc0a0bec55da3f47e234682a049b361f167a6c476ea601f72c4a8bc336c03bcbcbb1bbeccf5
-MISC metadata.xml 423 BLAKE2B f8cf1fb2d3fe5928d4a2d63c57a5fd896568560e36aeacc3c810a423782e56938f0e9bc278e4b76bb01232bc067e5cd29e5db34de3453150fda422486f39550b SHA512 fc7297de38eb7a18c666773502a30dc8e12e900c48322bd405567df260dc85ddce0b23f131d9783b4ff267f36131137d895a36c3eea21b8d3c5fc7fbcbbef5d4
+EBUILD ansible-pygments-0.1.1.ebuild 555 BLAKE2B d3645ad63a74c5766e2d3ed63d6623b798f572b10c3d46755ccc60905a5b7084bba7c49cc72218827ab2194bba6a24eddbb0d5e6876f1297126aa4563dc308a8 SHA512 816f5fc2545ea172fc68083b6361a6a9c2c9196a883e6374be6ec27316d9e1bf58ebb83d4274eff24e8e7b5f9cfcc5209294f3d2b169585a032534664d964276
+MISC metadata.xml 786 BLAKE2B 5883f03ffc7b0850bc8ecc90c91a15a9498ced9ee196a4f8d2a97a77a41957cb05a40ebf671ddbdf226886b94e9a5e796376094924712544a07559e0858aa5a8 SHA512 c7736962fe565be524294a30630e7cfd2820d1e9ace6f6dbd307ad46a252947ce368057d5ea5d20889a5ccdbb7f3418496affad5f8ed345e0e0808bd4abbe4ed
diff --git a/dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild b/dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild
new file mode 100644
index 000000000000..5883dcff29a8
--- /dev/null
+++ b/dev-python/ansible-pygments/ansible-pygments-0.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="poetry"
+
+inherit distutils-r1
+
+DESCRIPTION="Pygments lexer and style Ansible snippets"
+HOMEPAGE="https://github.com/ansible-community/ansible-pygments"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# 2.11.0+ needed in order for tests to pass
+RDEPEND=">=dev-python/pygments-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansible-pygments/metadata.xml b/dev-python/ansible-pygments/metadata.xml
index c29d69545a24..966223c0e2ad 100644
--- a/dev-python/ansible-pygments/metadata.xml
+++ b/dev-python/ansible-pygments/metadata.xml
@@ -5,6 +5,13 @@
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
+ <longdescription>
+ This project provides a <pkg>dev-python/pygments</pkg> lexer that is able to handle
+ <pkg>app-admin/ansible</pkg> output. It may be used anywhere Pygments is integrated.
+ The lexer is registered globally under the name "ansible-output".
+
+ It also provides a Pygments style for tools needing to highlight code snippets.
+ </longdescription>
<stabilize-allarches/>
<upstream>
<remote-id type="github">ansible-community/ansible-pygments</remote-id>