summaryrefslogtreecommitdiff
path: root/dev-python/ansicolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/ansicolor
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest4
-rw-r--r--dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild (renamed from dev-python/ansicolor/ansicolor-0.3.2.ebuild)23
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild16
3 files changed, 28 insertions, 15 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
index 182e6b9d6a5c..50a8c9cc8c54 100644
--- a/dev-python/ansicolor/Manifest
+++ b/dev-python/ansicolor/Manifest
@@ -1,4 +1,4 @@
DIST ansicolor-0.3.2.gh.tar.gz 118221 BLAKE2B f3f621298858974522dd05665c66ffebfc335291b61c6f0e6f835aaddf099559412f12979ad2a43001690b430125c8e1a8fd5427ad3268393d75bd736353d598 SHA512 de1e1bc9d8a02accaa57a64e5d2ea1f510545b3ab83218c47c7a1861e8438862c222147c9dcab0fcb1ec4055dcee07d6cde6d7bfecfbf9ac55c3bb76ac0fb0ab
-EBUILD ansicolor-0.3.2.ebuild 508 BLAKE2B 45a8286dbccd031d483b1112b909f2c0b5b4e68f8d4788ee3cef2536ac34858d426804ec9497474713c1713f9fb322785a67de35bc8e901eed908956fcb24b65 SHA512 f37d1d0f039cf9a1b6bf1e09ec068a41f938f19594c293415821dd61aad5a26e77dd997612965bcd7f9c03633d557b8beb8d30e8d8017a18f7d147c364ffd014
-EBUILD ansicolor-9999.ebuild 709 BLAKE2B 073ee48e67d63ad8b23fe0d712c110861e8bd9b53eff897af34a705984aa8e483fe842122ea7b3c151224b1eaf0d940468db3b59d6d294f34fc7cae879a139b3 SHA512 4bb1371073e06468a3c6080ccea1fe54ef024d97cfd352a753d8943f979ebd7cfbcfdd0546d4a034cdd9dae76bb1d67be90c8093ce2bb12636cc73e21cd5c6c4
+EBUILD ansicolor-0.3.2-r1.ebuild 779 BLAKE2B e7748ebe6126b9005500cce0c64dcef029f304be7d74271763a31290f45cd8ac28760ef86a3f694b23b6b67c764acf29bc116d2d9620de8109dec76c32ef0375 SHA512 7884d70baffcb19197cc749eb25bf55152d38a72560d0e19743305b7118a48ed8e1489aacc376352037bbc65d1ace473dcb6f9adb91821038e48f17c9a97337e
+EBUILD ansicolor-9999.ebuild 781 BLAKE2B 1b0e20fff8bd21766c06eb258f5be4fc3a083dcfe0421b69c50f0407767f5305c2bb24a971a177228e7ee2f00b851ec91175024b79c8188c49b9d7bc98058a62 SHA512 cf71a943f013dc4188c4f0b96dd38a812a136f76e683944705f80066397e396d5952c0944d12df07ad67ac2ba187f1f146291a8089f960c05fd6c3a6a4380c36
MISC metadata.xml 651 BLAKE2B 35a15ab72d6e81c682e4480b839b91854ed87bbb057e6977470d60a14208cb9da0ddee48bb959a75d5c5e665a322d9e56f6722ea37aa643c6e0c417fcd5246b0 SHA512 775b3298e84e89b35346e0a8f519e258a8b9af49a2bc879b54f80b6c4e696961b9a6a03794461620fdfdc83a163e54e5c37cfa505b52f9995fd2b9de44bf25ae
diff --git a/dev-python/ansicolor/ansicolor-0.3.2.ebuild b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
index 6151096e6f14..efd13944e8ac 100644
--- a/dev-python/ansicolor/ansicolor-0.3.2.ebuild
+++ b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
@@ -1,20 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
-DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
-HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
-SRC_URI="
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ SRC_URI="
https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 x86"
distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
index d678863551e3..ceb39bf7b7df 100644
--- a/dev-python/ansicolor/ansicolor-9999.ebuild
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
# pypi tars don't include tests and github repo is missing release tags,
# so only enabling tests for 9999 at this time
- distutils_enable_tests pytest
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,3 +25,5 @@ HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansico
LICENSE="Apache-2.0"
SLOT="0"
+
+distutils_enable_tests pytest