summaryrefslogtreecommitdiff
path: root/dev-python/antlr4-python3-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/antlr4-python3-runtime
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest3
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.9.3.ebuild21
-rw-r--r--dev-python/antlr4-python3-runtime/metadata.xml16
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
new file mode 100644
index 000000000000..26f42845b7fe
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -0,0 +1,3 @@
+DIST antlr-4.9.3.tar.gz 4640242 BLAKE2B fb58f5e533051cb2c439c32f0462c1d463c99df862ba7e1a37a1c61378ab36a9edb9525c2a342de5b517da6f02d8291de5976c550932314f3464aad1a778afb9 SHA512 61452404c9639b5a0908cda16605f17c0fed0c9adfc3278c7408f9971420e9d1fe8f9e974e0826c2e3e780fdd83324094c0246cd5b28fa63f5686b094ea08127
+EBUILD antlr4-python3-runtime-4.9.3.ebuild 534 BLAKE2B 13394f582021232d8a283bcb7cba8d0dc608d7200e95067c8d19a3a20c364ad60df42a7195af869e97a954f15f190c46816a6fdddbe47abf5c2b0fae2f90456a SHA512 64f383bfbfc4fc0fa2b8dae0e9f41d472183875cfcc078f8cd2b9be9e17cdcbd4718d874792286f91386fbff840e043ff10ec5722ff8605f4ce09400363c115c
+MISC metadata.xml 475 BLAKE2B 12dd34c09572017544a99c3985f6a7ad6c163f999f43fbc7ef4903456fe2d7fc59a8571fa3337ebe5a49eb6efab0a657a1b82b484b55887c799af11c0e64e716 SHA512 44ddd959d9f77d7beb97f84888db46ca468ed79ca844f89bbcac57366f42e1c2a1689497e2c25a659d2a63026b3c85f8348a43ee0213573d4a85cbf77fdfb993
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.9.3.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.9.3.ebuild
new file mode 100644
index 000000000000..36924c849be3
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://github.com/antlr/antlr4/archive/${PV}.tar.gz -> antlr-${PV}.tar.gz"
+S="${WORKDIR}/antlr4-${PV}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/antlr4-python3-runtime/metadata.xml b/dev-python/antlr4-python3-runtime/metadata.xml
new file mode 100644
index 000000000000..542c7a870d6e
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">antlr/antlr4</remote-id>
+ <remote-id type="pypi">antlr4-python3-runtime</remote-id>
+ </upstream>
+</pkgmetadata>