summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/anyio
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest3
-rw-r--r--dev-python/anyio/anyio-3.2.1.ebuild47
-rw-r--r--dev-python/anyio/files/anyio-3.2.1-missing-trio.patch125
3 files changed, 175 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 37ba2f1417ed..7d51dda385bc 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,5 +1,8 @@
+AUX anyio-3.2.1-missing-trio.patch 4024 BLAKE2B 7f53d13f07dc1a8fea86c5b9c44a07cd2f2da61159eacbe4043246ada988ab7a57e894b9dbf58185a20f39ada7794268a65ae6868a5f8501bcb363fdf95f776c SHA512 a53ee1bc475f34eb6be535bcde0ed67ed626e6e0576fcfd51ef700370bca3be8bb9c5f89fd69a9de36ce717b05246564f0204e27038f0d48f2ab6039643aeb1c
DIST anyio-3.1.0.tar.gz 122097 BLAKE2B 4a16a5d231cc5262dd4138f628b9d210180733bda4b9e81ced0c0e0c7f49e1760c8dd22db0a1db3b7a21f3210072f4e1c543e52a7dc716ad3f0415827da48e38 SHA512 120d8e3e24f542c06caedd0a67d16b3fb69c94f5feaebde5262e54f8ffba3f1cf927c82030d65fa2efb3479ee64abd968b6ce67aee767ea33ccef6b0e3fbd358
DIST anyio-3.2.0.tar.gz 126210 BLAKE2B cedace636a115ad579ca47b345bb2a9bb32e97fa2ef886a9e6bd19219dcc92c393aaaf480df5e6f48c959590c2d6a3e0770f700ab4901c7a8e576b231597abf1 SHA512 f4e718704225d9cbb8e2592246ac393f96e82fb1898bc0ff89b2d7990c4aac7e7c9b339cb57a594c59a9e5730696122c9e647310c26e00ab152879e0a7e85863
+DIST anyio-3.2.1.tar.gz 126277 BLAKE2B 510980c9251081d5188f7654279753051cd9f8221f2090fb99624612e48b6f5fc1f6d9f1808f1c329c350857f14ceaee0d72615857171de33dc35cc7ba35ab23 SHA512 ef78e5531a917e3a5ddc1106f45ba556ca147e52ab29ed6cb25a3bd287148a15a015942dde6b9535d683fbe5910affed27df6ce5c4049251610f689cd151ee89
EBUILD anyio-3.1.0.ebuild 1413 BLAKE2B 35471e090dad1e7d2a820c2c1d225e211311f673bf8d4a6d1adf5d0221d293fad3813295b17ddac496f603a1e26737b7bd43135361f4c5cfbfd29b48fd479f21 SHA512 dff8ec2ff5c87f0bea1d083fe62685c4580580e17bcedb14b014396a280e2468cd548b44bb492e5b64b09c61c49a4f86f043dcbd7e4a1bddb58b8bfff5b443de
EBUILD anyio-3.2.0.ebuild 1418 BLAKE2B 398427069cbee61cf7ae0111c76933c8908760619f4fd6c26622bafbe68e58287af7d916418aea7b06c8c96b928aefc5242bbebfece4ce9e03676b11b1d0510c SHA512 eb3abcab9ad4e5e26dc861508f881e3f96895eb120951be2be685c0727b0efa9a240a57caaf530076bcce8b229514fd1c80fc0f41bdf13a433aaf8ffc97c795d
+EBUILD anyio-3.2.1.ebuild 1033 BLAKE2B f080636c88b3790a3eceace45ec5e7074bf703cd76a74eb721a53f31ad594bf616d8b66061b5c20a6117db99709622e5c370caa8e76ce9775876f031eba01543 SHA512 555b14800a4f043d53416ebe9b9dde35865242c9d3321d60926d7f430eea5bbaac5880b309ee87e05e0b32728a6b774bbf9c81bd4fa42067a56ce7978969c69d
MISC metadata.xml 1320 BLAKE2B 0687bd9663338d0f39ad5b705f3ba3064ad7a399e31e6b6dfba80124b4ce719bbde82fb39f8b19b4a2fd22a040919163a59bfb57a3db143983d60db78d05811e SHA512 306491b404e5929eb19f61e359741b2961b3e600e3e6190e29215ea571db2d270d469c331956246f3336e05f5379d37d35bbea30931a9bbd8fb79a671d7642ce
diff --git a/dev-python/anyio/anyio-3.2.1.ebuild b/dev-python/anyio/anyio-3.2.1.ebuild
new file mode 100644
index 000000000000..7727ceecc614
--- /dev/null
+++ b/dev-python/anyio/anyio-3.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio
+ https://pypi.org/project/anyio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.15[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-trio.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ epytest -Wdefault -m 'not network' -p no:django
+}
diff --git a/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch b/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch
new file mode 100644
index 000000000000..492fe40fe70e
--- /dev/null
+++ b/dev-python/anyio/files/anyio-3.2.1-missing-trio.patch
@@ -0,0 +1,125 @@
+From d05f92bddc4b34a8d527f66d5d27513cd91c741a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 24 Jun 2021 09:16:01 +0200
+Subject: [PATCH] Handle missing trio gracefully
+
+Make it possible to use anyio without actually having to install trio.
+This involves modifying get_all_backends() to only return the backends
+that are actually present, and teaching the tests to skip trio if it
+is not importable.
+---
+ src/anyio/_core/_eventloop.py | 13 +++++++++----
+ tests/conftest.py | 9 ++++++++-
+ tests/test_pytest_plugin.py | 2 +-
+ tests/test_taskgroups.py | 10 ++++++++--
+ 4 files changed, 26 insertions(+), 8 deletions(-)
+
+diff --git a/src/anyio/_core/_eventloop.py b/src/anyio/_core/_eventloop.py
+index f2364a3..431a922 100644
+--- a/src/anyio/_core/_eventloop.py
++++ b/src/anyio/_core/_eventloop.py
+@@ -10,8 +10,6 @@ import sniffio
+ # This must be updated when new backends are introduced
+ from ._compat import DeprecatedAwaitableFloat
+
+-BACKENDS = 'asyncio', 'trio'
+-
+ T_Retval = TypeVar('T_Retval')
+ threadlocals = threading.local()
+
+@@ -106,8 +104,15 @@ def current_time() -> DeprecatedAwaitableFloat:
+
+
+ def get_all_backends() -> Tuple[str, ...]:
+- """Return a tuple of the names of all built-in backends."""
+- return BACKENDS
++ """Return a tuple of the names of all available built-in backends."""
++ backends = ['asyncio']
++ try:
++ import trio
++ except ImportError:
++ pass
++ else:
++ backends.append(trio)
++ return tuple(backends)
+
+
+ def get_cancelled_exc_class() -> Type[BaseException]:
+diff --git a/tests/conftest.py b/tests/conftest.py
+index f040ac8..5834395 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -8,6 +8,11 @@ import trustme
+ from _pytest.fixtures import SubRequest
+ from trustme import CA
+
++try:
++ import trio
++except ImportError:
++ trio = None
++
+ uvloop_marks = []
+ uvloop_policy = None
+ try:
+@@ -30,7 +35,9 @@ pytest_plugins = ['pytester']
+ id='asyncio'),
+ pytest.param(('asyncio', {'debug': True, 'policy': uvloop_policy}), marks=uvloop_marks,
+ id='asyncio+uvloop'),
+- pytest.param('trio')
++ pytest.param('trio',
++ marks=[pytest.mark.skipif(trio is None,
++ reason='trio is not available')])
+ ])
+ def anyio_backend(request: SubRequest) -> Tuple[str, Dict[str, Any]]:
+ return request.param
+diff --git a/tests/test_pytest_plugin.py b/tests/test_pytest_plugin.py
+index bb254a5..d55d511 100644
+--- a/tests/test_pytest_plugin.py
++++ b/tests/test_pytest_plugin.py
+@@ -135,7 +135,7 @@ def test_asyncio(testdir: Testdir) -> None:
+ )
+
+ result = testdir.runpytest('-v')
+- result.assert_outcomes(passed=2, failed=1, errors=2)
++ result.assert_outcomes(passed=2, failed=1, errors=len(get_all_backends()))
+
+
+ def test_autouse_async_fixture(testdir: Testdir) -> None:
+diff --git a/tests/test_taskgroups.py b/tests/test_taskgroups.py
+index 62a2389..47971c0 100644
+--- a/tests/test_taskgroups.py
++++ b/tests/test_taskgroups.py
+@@ -5,7 +5,6 @@ import time
+ from typing import Any, AsyncGenerator, Coroutine, Dict, Generator, NoReturn, Set
+
+ import pytest
+-import trio
+
+ import anyio
+ from anyio import (
+@@ -13,6 +12,11 @@ from anyio import (
+ fail_after, get_cancelled_exc_class, move_on_after, sleep, wait_all_tasks_blocked)
+ from anyio.abc import TaskGroup, TaskStatus
+
++try:
++ import trio
++except ImportError:
++ trio = None
++
+ if sys.version_info < (3, 7):
+ current_task = asyncio.Task.current_task
+ else:
+@@ -53,7 +57,9 @@ async def test_success() -> None:
+
+ @pytest.mark.parametrize('module', [
+ pytest.param(asyncio, id='asyncio'),
+- pytest.param(trio, id='trio')
++ pytest.param(trio, id='trio',
++ marks=[pytest.mark.skipif(trio is None,
++ reason='trio is not available')])
+ ])
+ def test_run_natively(module: Any) -> None:
+ async def testfunc() -> None:
+--
+2.32.0
+