summaryrefslogtreecommitdiff
path: root/dev-python/apispec/apispec-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 13:50:34 +0100
commit7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (patch)
treea6a3e9599958059e99a9753cffba162ceb14b9b9 /dev-python/apispec/apispec-6.0.0.ebuild
parentafc11599d81c08d253ed16222206ccd408d6c3cf (diff)
gentoo auto-resync : 15:10:2022 - 13:50:34
Diffstat (limited to 'dev-python/apispec/apispec-6.0.0.ebuild')
-rw-r--r--dev-python/apispec/apispec-6.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/apispec/apispec-6.0.0.ebuild b/dev-python/apispec/apispec-6.0.0.ebuild
new file mode 100644
index 000000000000..b82fa25e0226
--- /dev/null
+++ b/dev-python/apispec/apispec-6.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)