summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
commita15e8dc7444560123d7d4be1bccb19afd5b611d0 (patch)
tree6e26ee0323c09494a66d0f78c4b81e305bb0d096 /dev-python/apispec
parent3dc4de6331223493015f198dc61854af604da86c (diff)
gentoo auto-resync : 22:10:2024 - 04:04:46
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest2
-rw-r--r--dev-python/apispec/apispec-6.7.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 05a925bf1a67..972f797eaf50 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,5 @@
DIST apispec-6.6.1.tar.gz 76537 BLAKE2B e08f1545441be7f1dd266205a6a7dc1317385961325e47c25fde0aecbd68712410601249bced9b0c3491d3e6f772c94c14f638d77e3dbfac37bba5bb0dd1e284 SHA512 a6820444b017f9551d21cf5ba5a14f8f4eaa6bccd1848c540e41bd37140df06dc897bf5d29bc77a2e55b670d58dc84eeb6588769efb3fe400eba243c0a1b5425
+DIST apispec-6.7.0.tar.gz 76654 BLAKE2B 95b0daa8c6b07bd4accf84a8f4259d9c7ebed34ad0e9767c53548b13a82bc0de7bf3b145905f380106bfc07cfa10a942f290d93d1d3599aa8fe76df23863a3b3 SHA512 b75482696aecd6a68bd35ba1e4112c3ead7475c7f5dcca49f0ec6f332f37ed8e42df152164b645716f86daaafbb59f94c3f4844705d3df5263e637e9fa90afcd
EBUILD apispec-6.6.1.ebuild 1017 BLAKE2B 17411418f95b290ad4ff867527a2f23928256d9e4a34837c96aa57a55a9328340649b7c2ed1bcdb1b7775aa243746b40863303c6bbed73cecf577791ed63c365 SHA512 ab1bd961a10ca1163c895f1c80571c3650d027a0e094788e807641c32dfb59fa6432e0a8042e04a8c1717dd3a4bcac8253ec8273a0d635f0f3fce9fdcd355302
+EBUILD apispec-6.7.0.ebuild 1017 BLAKE2B 17411418f95b290ad4ff867527a2f23928256d9e4a34837c96aa57a55a9328340649b7c2ed1bcdb1b7775aa243746b40863303c6bbed73cecf577791ed63c365 SHA512 ab1bd961a10ca1163c895f1c80571c3650d027a0e094788e807641c32dfb59fa6432e0a8042e04a8c1717dd3a4bcac8253ec8273a0d635f0f3fce9fdcd355302
MISC metadata.xml 504 BLAKE2B d55ae521520ba60a139e83f23aacbb3df76c4c120a54f1b65b185018647c1f363bc88f354abc1810b7a9d9f3cfa264e0303d46cd23b8091dbb365bd84cc04815 SHA512 e0297e941c3c544cbb14044f02451c26cfdec81b2bd49cf225dc9f32d1ccb207e630d838d8928d28ccb35a3cf01493a87ceb2633cc5ede36b62a6d81f164ea32
diff --git a/dev-python/apispec/apispec-6.7.0.ebuild b/dev-python/apispec/apispec-6.7.0.ebuild
new file mode 100644
index 000000000000..b4c64b64045b
--- /dev/null
+++ b/dev-python/apispec/apispec-6.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}