summaryrefslogtreecommitdiff
path: root/dev-python/apispec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/apispec
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest3
-rw-r--r--dev-python/apispec/apispec-3.3.0.ebuild33
-rw-r--r--dev-python/apispec/files/apispec-3.3.0-tests.patch20
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index afa71f8b65ef..f5fbe2cbe96b 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1,3 +1,6 @@
+AUX apispec-3.3.0-tests.patch 697 BLAKE2B 5bec31aa9f049547921a73a21f5065da40881e1f587a3924f2ca2aabc1876c9d9026cf9c77b8111427d8315b75dc0ed13ee29c094b3336436453e9ecccdaab5e SHA512 b4c764b340b3630dfc3a2ece59858d6e2f03d4718e8b57f828a8db51954cc7c6656e0a6af8d1e6eee034cf4a2a2226cd170bfa3a0b687855ed2e1d52a67834e5
DIST apispec-0.35.0.tar.gz 47684 BLAKE2B 3067a0d50a6f53378f46a9a07596da53679f399732619f5bd3d1bedd85d088c6901560dc46be22b42d77537c437d9d97840a55f0b1513e39c87760e9e6c8ea0c SHA512 45a3034c49169ca7998480a8b8e0ac6415d49b6235885fba31eaaccb1c008b4ea845a6743f10cc3492215affe20b690d73a9a06e0e0c3942e0327f381415fa57
+DIST apispec-3.3.0.tar.gz 66952 BLAKE2B a744230a1754d88b3bdc2325916e100d1de19bdf0e7985245d9f0ecf4a6bd9c778e502be73107a90a3676e8ecda45653d9f0962d33f68c6242bc52dc4695b1cb SHA512 f8cfaeec9486554653a09ce37cf2aa11b037047aa3af918a1273a4ca892d723c9367827cb3a034683722965f17dc8ed45ce3f163631c666902a3a87b5485b537
EBUILD apispec-0.35.0.ebuild 809 BLAKE2B d456eeff4a9e93bc6967746ae7a6a7e31cac04a7da2d2da8ec80bc61b23a4f045e21c9b76d5014524debfa13d3cf94b497396c6dc786495828f740ab92f7dbd4 SHA512 34e4340ae0af84b2f49dcc00fcb06f7182497125dbeeadd7bc6ff27b54c9817676efc35e4f2041b2d91b592f917a966cc9b97d22ae542a9633986afaf2ddf7c9
+EBUILD apispec-3.3.0.ebuild 746 BLAKE2B 6c4f1b217c28de70c885c6bbf817828e3b5e208034e50c5c83da02af0ff403c359dbadf2e0a14a2896a8680b238b69acc26e2a80508c4e700d196677a02821b4 SHA512 c02cfc7772b4183b473736658cbf70f6494656c3a12c6c71d26535c1a7dee52182e264c043b13f59af4892b23db832d4e11da2854ae34188592a67d8d199cf66
MISC metadata.xml 352 BLAKE2B e072e5a12d891408ee029e0f51b9c2a232e8a31e941352d43695e0bec949c4f0d1d709707c052971a3bac490763d3f79a264bf85cf97e6f6b2bd62064f1fbcc7 SHA512 ba1e41f1977b0afa34de52bbd96bba0c4e517e5f6b0094356d37c36b4365cd7ffaa055caef08888a4e1da912e1d3616e8545cb6f8de20538ea15f338a5dfb0f6
diff --git a/dev-python/apispec/apispec-3.3.0.ebuild b/dev-python/apispec/apispec-3.3.0.ebuild
new file mode 100644
index 000000000000..df2a9b020bce
--- /dev/null
+++ b/dev-python/apispec/apispec-3.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/apispec-3.3.0-tests.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/apispec/files/apispec-3.3.0-tests.patch b/dev-python/apispec/files/apispec-3.3.0-tests.patch
new file mode 100644
index 000000000000..fb2ffc549207
--- /dev/null
+++ b/dev-python/apispec/files/apispec-3.3.0-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_ext_marshmallow_openapi.py b/tests/test_ext_marshmallow_openapi.py
+index ab1b0b8..d151a32 100644
+--- a/tests/test_ext_marshmallow_openapi.py
++++ b/tests/test_ext_marshmallow_openapi.py
+@@ -454,6 +454,7 @@ class TestNesting:
+ assert "breed" not in category_props
+
+
++@pytest.mark.skip("test requires extra dependencies")
+ def test_openapi_tools_validate_v2():
+ ma_plugin = MarshmallowPlugin()
+ spec = APISpec(
+@@ -512,6 +513,7 @@ def test_openapi_tools_validate_v2():
+ pytest.fail(str(error))
+
+
++@pytest.mark.skip("test requires extra dependencies")
+ def test_openapi_tools_validate_v3():
+ ma_plugin = MarshmallowPlugin()
+ spec = APISpec(