summaryrefslogtreecommitdiff
path: root/dev-python/aplpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aplpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aplpy')
-rw-r--r--dev-python/aplpy/Manifest7
-rw-r--r--dev-python/aplpy/aplpy-1.0.ebuild52
-rw-r--r--dev-python/aplpy/aplpy-1.1.1.ebuild58
-rw-r--r--dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch14
-rw-r--r--dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch121
-rw-r--r--dev-python/aplpy/metadata.xml18
6 files changed, 270 insertions, 0 deletions
diff --git a/dev-python/aplpy/Manifest b/dev-python/aplpy/Manifest
new file mode 100644
index 000000000000..5602440d96dc
--- /dev/null
+++ b/dev-python/aplpy/Manifest
@@ -0,0 +1,7 @@
+AUX aplpy-1.0-fix-dependencies.patch 456 BLAKE2B 556271cdf233cc2358d6be0daaeb63122b687e7b820b02ba6113f3c2cc54243fd860a2aaa943ddbbc8c8f5af74d241b7c525dca191346f5a777c38e7aa096278 SHA512 b0b0ac53fe6702947d21fbe1cbe60c6dfe5047fd74e54cb5ff02e2adfc8f6c53a3da14681cc6aa5f441a90aa3478555b558be6a1be96111d380c0b8da55c5185
+AUX aplpy-1.0-mark-known-failures.patch 3738 BLAKE2B 56dc68f826e4f1a657030fa8fe3cf1587229c516c04ccc659a8bf8e0d2f9e8f4bdea58dd68c48d86effb2dddbf597e12f17ca36c158ae9ae448711a1a6940019 SHA512 e076921616ecb528844b79f330b1901958ed12e4985063ee2829ff361b93cc457b23caa9107c79c58028a53e97b085033b8666681d2ece7ef24b9bdd9d955ce8
+DIST APLpy-1.0.tar.gz 1169280 BLAKE2B 10c7133c5708412741e25b85f3286d28ab36c5ab69fa65dcbb8b1607c171f1fc5c7b341fea8255176a90d97e18c7a5071d9f3e7848558ee66f7f48de0cf9ea09 SHA512 658b626c2a94c73cc8ba45fde86409659555ed3ec065d07313f08b67c0bcdc596c8dc94562c924de2f3f32d6884051e6756e22384d9594c4538578b482fa7590
+DIST APLpy-1.1.1.tar.gz 938943 BLAKE2B 1b5ca8f1312a0bccea46a3d7bf3dd8cc7a003083cc321147d24c650abe6bc77c3b2398db64687d3603a1077f3253a1cccf37efe874148c681393563991f96b43 SHA512 accc355fb56145db33a931b77b9d5b56e5e0f5a486a3a8d776b0645991883df4b78fae58cfe87c1575dad7f02baa5c68c95427c1de18c2435abd13c4a85eee93
+EBUILD aplpy-1.0.ebuild 1212 BLAKE2B 1e4109228e610d30519822e961b782a33ea4955229be3400c1d0795b3dd848ce56fdf054655b41c9743444c7c6b3493eba12247fd7c99767f58d4bd8e07e3576 SHA512 e91e5a43b697fff15c14e7b3e29f5b3cf59bc054199a52cb8cc04082eb1022b0a94f5ebe652e55daf772d7c1dcb524ab8df7f310b39ef16d5bff661da2f28931
+EBUILD aplpy-1.1.1.ebuild 1456 BLAKE2B 174658254fce3e6dc76e5f89c381785133f919ad956a7cb8ae9ca4536dbb6d0dc84209984891ff382d05fe6ad1fb4b5e16979a7d271ab5b0fccbae60b538cc41 SHA512 3aab3a4a1f4f5f63bfc022640c446d07634de82b0d49cd7f9cd49a2a119513e561168d729113e05e06bee681e20d5d124d44a4f18b97668dec4fb265684cd9fc
+MISC metadata.xml 698 BLAKE2B eda7318fcd5f52478bb03e0259fa991042759ff55409c42f44ccd9d0ac8220cce6aadfaccd71c8934fb33650e55af30e3b644f0920fb15cc74a8c65eea479ba7 SHA512 33e925cde2dd0ff56a158426d35d5f498fddcb352042c4acd868b577ca00893fa2bf2f9ff33b8931578af4841ba08abfea159003bc33be4c579bf51ac8cad1df
diff --git a/dev-python/aplpy/aplpy-1.0.ebuild b/dev-python/aplpy/aplpy-1.0.ebuild
new file mode 100644
index 000000000000..8f9f5bd54fe3
--- /dev/null
+++ b/dev-python/aplpy/aplpy-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+MYPN=APLpy
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Astronomical Plotting Library in Python"
+HOMEPAGE="https://aplpy.github.com/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyavm[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0-mark-known-failures.patch"
+ "${FILESDIR}/${PN}-1.0-fix-dependencies.patch"
+)
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ virtx "${EPYTHON}" -c "import aplpy, sys;r = aplpy.test();sys.exit(r)"
+}
diff --git a/dev-python/aplpy/aplpy-1.1.1.ebuild b/dev-python/aplpy/aplpy-1.1.1.ebuild
new file mode 100644
index 000000000000..295c6eeef5e9
--- /dev/null
+++ b/dev-python/aplpy/aplpy-1.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+MYPN=APLpy
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Astronomical Plotting Library in Python"
+HOMEPAGE="https://aplpy.github.com/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0-fix-dependencies.patch"
+)
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ virtx "${EPYTHON}" -c "import aplpy, sys;r = aplpy.test();sys.exit(r)"
+}
+
+pkg_postinst() {
+ optfeature "Interact with Montage" dev-python/montage-wrapper
+ optfeature "Read DS9 regions files" dev-python/pyregion
+ optfeature "Extend image i/o formats" dev-python/pillow
+ optfeature "Astronomy Visualization Metadata tagging" dev-python/pyavm
+}
diff --git a/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch b/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch
new file mode 100644
index 000000000000..b5708c8971bc
--- /dev/null
+++ b/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch
@@ -0,0 +1,14 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Change requires to install_requires
+--- a/setup.py
++++ b/setup.py
+@@ -94,8 +94,7 @@
+ version=VERSION,
+ description=DESCRIPTION,
+ scripts=scripts,
+- requires=['astropy', 'numpy', 'matplotlib'],
+- install_requires=['astropy'],
++ install_requires=['astropy', 'numpy', 'matplotlib'],
+ provides=[PACKAGENAME],
+ author=AUTHOR,
+ author_email=AUTHOR_EMAIL,
diff --git a/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch b/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch
new file mode 100644
index 000000000000..cf1aa92190d4
--- /dev/null
+++ b/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch
@@ -0,0 +1,121 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Mark tests that are known to fail with matplotlib-1.5
+--- a/aplpy/tests/test_images.py
++++ b/aplpy/tests/test_images.py
+@@ -61,6 +61,8 @@
+
+ class TestBasic(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for showing grayscale
+ def test_basic_image(self, generate):
+ f = FITSFigure(self.filename_2)
+@@ -68,6 +70,8 @@
+ self.generate_or_test(generate, f, 'basic_image.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_ticks_labels_options(self, generate):
+ f = FITSFigure(self.filename_2)
+ f.ticks.set_color('black')
+@@ -84,6 +88,8 @@
+ self.generate_or_test(generate, f, 'tick_labels_options.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for showing colorscale
+ def test_show_colorbar_scalebar_beam(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -96,6 +102,8 @@
+ self.generate_or_test(generate, f, 'colorbar_scalebar_beam.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for overlaying shapes
+ def test_overlay_shapes(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -112,6 +120,8 @@
+ self.generate_or_test(generate, f, 'overlay_shapes.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for grid
+ def test_grid(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -125,6 +135,8 @@
+ self.generate_or_test(generate, f, 'grid.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test recenter
+ def test_recenter(self, generate):
+ f = FITSFigure(self.filename_2)
+@@ -135,6 +147,8 @@
+ self.generate_or_test(generate, f, 'recenter.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test overlaying contours
+ def test_contours(self, generate):
+ data = np.arange(256).reshape((16, 16))
+@@ -144,6 +158,8 @@
+ self.generate_or_test(generate, f, 'contours.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test cube slice
+ def test_cube_slice(self, generate):
+ f = FITSFigure(self.filename_3, dimensions=[2, 0], slices=[10])
+--- a/aplpy/tests/test_rgb.py
++++ b/aplpy/tests/test_rgb.py
+@@ -6,6 +6,7 @@
+
+ import numpy as np
+ from astropy.io import fits
++from astropy.tests.helper import pytest
+
+ from .. import FITSFigure
+ from ..rgb import make_rgb_image
+@@ -17,6 +18,8 @@
+
+ class TestRGB(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_rgb(self, generate, tmpdir):
+
+ # Regression test to check that RGB recenter works properly
+--- a/aplpy/tests/test_vectors.py
++++ b/aplpy/tests/test_vectors.py
+@@ -1,4 +1,5 @@
+ import numpy as np
++from astropy.tests.helper import pytest
+
+ from ..core import FITSFigure
+
+@@ -15,6 +16,8 @@
+
+ class TestVectors(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_default(self, generate):
+ f = FITSFigure(IMAGE, figsize=(4,4))
+ f.show_grayscale()
+@@ -22,6 +25,8 @@
+ self.generate_or_test(generate, f, 'vectors_default.png', tolerance=2.5)
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_step_scale(self, generate):
+ f = FITSFigure(IMAGE, figsize=(4,4))
+ f.show_grayscale()
diff --git a/dev-python/aplpy/metadata.xml b/dev-python/aplpy/metadata.xml
new file mode 100644
index 000000000000..8fa6a8c707bb
--- /dev/null
+++ b/dev-python/aplpy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ APLpy (the Astronomical Plotting Library in Python) is a Python
+ module aimed at producing publication-quality plots of astronomical
+ imaging data in FITS format. The module uses Matplotlib. It is
+ capable of creating output files in several graphical formats,
+ including EPS, PDF, PS, PNG, and SVG.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">APLpy</remote-id>
+ </upstream>
+</pkgmetadata>