summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
commit3cba520665a0461aa7b0ada016f4a0df717e37a2 (patch)
tree2a653051c7ea63b16724a5da9d583994530ab97b /dev-python/apprise
parent8c39538f1e5cf37f42c409a6c742f96abef56f3b (diff)
gentoo auto-resync : 25:12:2023 - 01:35:27
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest3
-rw-r--r--dev-python/apprise/apprise-1.6.0.ebuild35
-rw-r--r--dev-python/apprise/metadata.xml17
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
new file mode 100644
index 000000000000..e48489c902ed
--- /dev/null
+++ b/dev-python/apprise/Manifest
@@ -0,0 +1,3 @@
+DIST apprise-1.6.0.tar.gz 1582966 BLAKE2B aec28c82a2e1b45341f1e67a0778be2a9149ff591172122abb7d30eeed27c7b49171556993c0f1c0d33fe12a5dcdeb4ad0ade8b9e68a8f9950a3f8b6f0638156 SHA512 572d0cb9e3464ea2bc65a101e520dd0b15ada08c158a21d1ac698adbcd454ecf5af7ad30dca6495b4d7e38b92128774c43864c011f1af26ad917699e1d50c59b
+EBUILD apprise-1.6.0.ebuild 884 BLAKE2B 42b346cda094d67ac99425cb65efd2e2a79f0e20f3141de18d054162542290d1bbca2913c77409871338934c936b779e6b2bd16a71836b25581aae413e660429 SHA512 5226be185bbde7fd87a65363980ea782e5053b24c32d75ebfbc1f01d93d517168f554a9a8e1858f71cb3ae4ad156d20dc840ffc78ee053758d08af848c00b2a7
+MISC metadata.xml 559 BLAKE2B 1a8270085b43930488155404867d26c354c5feee8baaf934eb83bd5ff52d7f08cb787fe5063323ebcd8fc85d630c6b79c5f0be9c7653baa298981fe9140bad35 SHA512 838e1ad03125406937967899ce418725ef5cf09b92fcf2953efc3b0636a387922f0152da82f3394067a062cbcfa849b3eb9be0cba776732f6e5c8af74c3a041e
diff --git a/dev-python/apprise/apprise-1.6.0.ebuild b/dev-python/apprise/apprise-1.6.0.ebuild
new file mode 100644
index 000000000000..17d45d5fc40b
--- /dev/null
+++ b/dev-python/apprise/apprise-1.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+#FIXME
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="dev-python/Babel[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/apprise/metadata.xml b/dev-python/apprise/metadata.xml
new file mode 100644
index 000000000000..fd8dbf3c5236
--- /dev/null
+++ b/dev-python/apprise/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">apprise</remote-id>
+ <remote-id type="github">caronc/apprise</remote-id>
+ </upstream>
+ <use>
+ <flag name="dbus">Support sending notifications to the desktop over D-Bus</flag>
+ <flag name="mqtt">Support sending notifications over MQTT</flag>
+ </use>
+</pkgmetadata>