summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
commit56330f065f2b903d9e1b2dffc63719fef5897a45 (patch)
tree659a7ebca7cb9f7504b018c1484df84ba4f9ab01 /dev-python/apprise
parent1774f0a748546cbd792bf1eb44757b63be2e0114 (diff)
gentoo auto-resync : 06:01:2024 - 12:54:38
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest4
-rw-r--r--dev-python/apprise/apprise-1.7.1.ebuild38
-rw-r--r--dev-python/apprise/metadata.xml4
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 1ccd919cf05f..996d49bec957 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.6.0.tar.gz 1582966 BLAKE2B aec28c82a2e1b45341f1e67a0778be2a9149ff591172122abb7d30eeed27c7b49171556993c0f1c0d33fe12a5dcdeb4ad0ade8b9e68a8f9950a3f8b6f0638156 SHA512 572d0cb9e3464ea2bc65a101e520dd0b15ada08c158a21d1ac698adbcd454ecf5af7ad30dca6495b4d7e38b92128774c43864c011f1af26ad917699e1d50c59b
+DIST apprise-1.7.1.tar.gz 1633347 BLAKE2B 4b51ffc45b61b4ff46cb3c0bd80c2f14a11d827ca350fe18fc6350934e3b93c09a98d03fd609d051311e46181778d433ae5813cb269623fed83ce47a7203eab3 SHA512 317e9fa057c7db28f73ea0888f378b036413a5a3186172206c3af57083a8d1965db178c89acfb2048bd82e5f530f65c05bfde3bb9c8aea7c9dd2f78e13e0a8b7
EBUILD apprise-1.6.0.ebuild 877 BLAKE2B abe897168b06f5319f2be16c173b5dbb3db59587e1a2181fcd84ffd91c80c972d9accca3f934280b4dcb3fd13e1dc028e2ada2ba2fe217b995e5acab3b79b79e SHA512 9dec6a56a72c4a16887746ecbe99a2761f5b87cc1cde235de642a2276858b0a9131c0bc8fa49c2020b44b06877b7640bb62a4bbefe724129684e924d86667380
-MISC metadata.xml 559 BLAKE2B 1a8270085b43930488155404867d26c354c5feee8baaf934eb83bd5ff52d7f08cb787fe5063323ebcd8fc85d630c6b79c5f0be9c7653baa298981fe9140bad35 SHA512 838e1ad03125406937967899ce418725ef5cf09b92fcf2953efc3b0636a387922f0152da82f3394067a062cbcfa849b3eb9be0cba776732f6e5c8af74c3a041e
+EBUILD apprise-1.7.1.ebuild 883 BLAKE2B 9cee7c267bfbbfbab7c4a44229d2302168a4ce5ebc6860ea3bb3b2ec84a441f7865b2175a664ccda3136538d19b51509bc5d8ffe1e915092c982e4d0fd4bc024 SHA512 f7c9c32c8224871a8013e6a7c9dfaf4f140ef19425435bf414eb7a72a7716a97cb4538aade15ac39293dcf8bddd2b6fb674d157f8d9a02e8353d59dcbeee3dc6
+MISC metadata.xml 660 BLAKE2B e5d3535632acf00f228e96b2deca73aca518faf9f9e3ec032e13fdea4480e3f83791b3846e456ae47a917a3462c47882358c3ea1c69d20b6332a6ade65340211 SHA512 4c69871bdd771b7cc1af57e018ed1cc1f2194bdf2f7c1e750433911cf75e45f8fa4aa82df71255ce0a1c949db9d220ed614d5932ccf1ff5e78976bec482751a6
diff --git a/dev-python/apprise/apprise-1.7.1.ebuild b/dev-python/apprise/apprise-1.7.1.ebuild
new file mode 100644
index 000000000000..d13a9429e726
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/apprise/metadata.xml b/dev-python/apprise/metadata.xml
index fd8dbf3c5236..c53896f64200 100644
--- a/dev-python/apprise/metadata.xml
+++ b/dev-python/apprise/metadata.xml
@@ -5,6 +5,10 @@
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">apprise</remote-id>