summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
commitd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (patch)
treeb8041134209c7d8f47560e719b584508ea78180f /dev-python/apprise
parent9991465b0b90d77b2a8a2ae833b6ecd99e6b5101 (diff)
gentoo auto-resync : 09:01:2025 - 06:41:15
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest2
-rw-r--r--dev-python/apprise/apprise-1.9.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 6218ec638b02..1220eb799bfc 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.9.1.tar.gz 1778862 BLAKE2B 5c2d919e7d2f105f0636de6495a7ab450551e6cb2fb806f6f28e8f0bc1370c88e1ed0f55bc350a9828def787a43694bc519020ab522c06b70b648e4aefc187dc SHA512 02b96e6bf88858631d62fef7215d25b383015e916f8031fa01c30a44bb15ff6afd9eb8198e99ce107072f2802db25f5abfa033bb2e9752f559b4c6c40f99ac80
+DIST apprise-1.9.2.tar.gz 1779362 BLAKE2B 903cd3fdabb4c00348687de447adcc30dfcb8cfee797e9a661b6278ea249b5c03baba701a0716d5d9efca5e77ed3b4ff05a7aa136ec54d2ebfb7a8ef47ba76c6 SHA512 57316bcce6de3ce6dbe19eee6a8bebfa8a3e10066054c47f3225c4fed397762c749939b29d2eb86460698662d125f97898551004d1e02886b31a0c46d41e7875
EBUILD apprise-1.9.1.ebuild 894 BLAKE2B d4f5186497c9736a406953b0506ce610342d3df1866e0f2ee0aa75d84f1f7087b61382c4d10a377d6db1c81fb046aad3db42cb85b8f47c49afee67328a3adf7d SHA512 4f8d49b920449caab741b0a74b2661afe379bce208be1dff4093826f2a26111c75bc1bbbdee93fbceac52e40b2ae183dcc72f5046e30bb6a83eaf34516da4496
+EBUILD apprise-1.9.2.ebuild 895 BLAKE2B 1f898f7bf3fc32e3b0a430e58bfb953a4d6209e3d6f4711ab1e9ad77dcb5db73d8e2e4020da44bea03922f72ae24e8ff9dcd5a8b17727653d6695d02229aa07d SHA512 16b168169f52fa3a188cc43c241c690e01e2abf67b5288ed2caa58213fb9bc93e057ea796175da2289b424e79034578a2e724bb7b808930f8238bb52be463fc5
MISC metadata.xml 554 BLAKE2B 5d232c4d5835c5e782d37d9d1697029d4f49c1dfde65cee0527bfd2ed31bb67d680a6a3aa406c2fc1ba033c40efde1e239f2b66996a23c7089d4e6d8a3beb411 SHA512 0e857c991e1347784d908b291a01dba19005985f4976a29fc76522872828f1491d2ece6e9755277167369198dc26beed623beaf9b3d4693a0e0d9e663830b29a
diff --git a/dev-python/apprise/apprise-1.9.2.ebuild b/dev-python/apprise/apprise-1.9.2.ebuild
new file mode 100644
index 000000000000..8094a0d6fd60
--- /dev/null
+++ b/dev-python/apprise/apprise-1.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest