summaryrefslogtreecommitdiff
path: root/dev-python/apsw/apsw-3.39.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
commit9d396115d657f4e18ffa2c1d073980d8e3d6710f (patch)
tree9f01ba3155b53183847eaf91e63b1e652ed6002f /dev-python/apsw/apsw-3.39.2.0.ebuild
parenta9b37934d0877c4249ea35c9e9c5b8cf3b836c9e (diff)
gentoo auto-resync : 01:08:2022 - 15:15:48
Diffstat (limited to 'dev-python/apsw/apsw-3.39.2.0.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.39.2.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/apsw/apsw-3.39.2.0.ebuild b/dev-python/apsw/apsw-3.39.2.0.ebuild
new file mode 100644
index 000000000000..68db175bfcfb
--- /dev/null
+++ b/dev-python/apsw/apsw-3.39.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+)
+
+python_compile() {
+ # Needed for e.g. bug #851741
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}