summaryrefslogtreecommitdiff
path: root/dev-python/astrodendro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/astrodendro
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/astrodendro')
-rw-r--r--dev-python/astrodendro/Manifest3
-rw-r--r--dev-python/astrodendro/astrodendro-0.2.0.ebuild57
-rw-r--r--dev-python/astrodendro/metadata.xml15
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/astrodendro/Manifest b/dev-python/astrodendro/Manifest
new file mode 100644
index 000000000000..b2a590fdf271
--- /dev/null
+++ b/dev-python/astrodendro/Manifest
@@ -0,0 +1,3 @@
+DIST astrodendro-0.2.0.tar.gz 4594802 SHA256 fa4fe942d1c6d80224bb8930fb5455275c70cd10211412634139bdd91fa1fce8 SHA512 2079e2844537b74b8c40a5e2d9c04a2e7940f12fa0ac77dc95f39d7ea623ad43d8635043336f5cedff6076599a44c4b8908dbd0b67d33c47310408496bce1b1d WHIRLPOOL 6cc56dcf8af8e7ea889c6c266e80de155eb1e10c38fc11c4e4b328bc78f23895a38bee45488499ed2a08b8cb3662e14a9a8d0b1adc6d5b29a850e0c70a7944bb
+EBUILD astrodendro-0.2.0.ebuild 1363 SHA256 cc2d3d6f33140851d70f1226d68a1bc1c1b7a29271dc1f8cfcb6620803e6bb47 SHA512 ae654fe0c9af5b33d407d5e3f457434209c957ead1a391310e2dc956dd3cca4abc81ca3ec64a5301dca042a5490d4cd361487ebb455fe3be66a8797564fed86f WHIRLPOOL f23ab76a4bb606c94def09d6873f67ee54ffaab3b886f480b5867ec30223bc50fd19bdcfb10ba9ff12dfdcfbf52db0917c744300946a4310117ad1d42559d572
+MISC metadata.xml 530 SHA256 3579b686589c3932e0558c8b4934c1bad21eb0eb2193db2e62a7ddfe045044e4 SHA512 939a42e5c9eca1901749e5ab2242cdd375df94cc85a68076825023a4bd48d7866400023b74d2ae7271d638bb706155cebb049b9e190aed0b286055937b9f8aa4 WHIRLPOOL ad440fbe815a5ac566c012559372a16fcaece88bb7e99181a1b847fa73bcfa367813a490c746ebab4b5398e56dc0245c0fe86ebcf20d433231ba00e16d0ddb67
diff --git a/dev-python/astrodendro/astrodendro-0.2.0.ebuild b/dev-python/astrodendro/astrodendro-0.2.0.ebuild
new file mode 100644
index 000000000000..44e8df2fdff0
--- /dev/null
+++ b/dev-python/astrodendro/astrodendro-0.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 xdg-utils virtualx
+
+DESCRIPTION="Python package for computation of astronomical dendrograms"
+HOMEPAGE="http://www.dendrograms.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astrodendro/metadata.xml b/dev-python/astrodendro/metadata.xml
new file mode 100644
index 000000000000..ea17c673072e
--- /dev/null
+++ b/dev-python/astrodendro/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The astrodendro package provides an easy way to compute
+ dendrograms of observed or simulated Astronomical data in Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astrodendro</remote-id>
+ </upstream>
+</pkgmetadata>