summaryrefslogtreecommitdiff
path: root/dev-python/astrodendro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/astrodendro
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/astrodendro')
-rw-r--r--dev-python/astrodendro/Manifest3
-rw-r--r--dev-python/astrodendro/astrodendro-0.2.0.ebuild57
-rw-r--r--dev-python/astrodendro/metadata.xml15
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/astrodendro/Manifest b/dev-python/astrodendro/Manifest
new file mode 100644
index 000000000000..77483603c3fa
--- /dev/null
+++ b/dev-python/astrodendro/Manifest
@@ -0,0 +1,3 @@
+DIST astrodendro-0.2.0.tar.gz 4594802 BLAKE2B 19499d75d6ecf024c399595926c41fcd19b7dda017cbde2d6466cc85c9a7e5eec15ea459691589dcc89013b3ca8c76532d85eb565635a526283a63e88b9fc5a2 SHA512 2079e2844537b74b8c40a5e2d9c04a2e7940f12fa0ac77dc95f39d7ea623ad43d8635043336f5cedff6076599a44c4b8908dbd0b67d33c47310408496bce1b1d
+EBUILD astrodendro-0.2.0.ebuild 1367 BLAKE2B 2d74384cd633393b9ffcd6d73f83883a7bb656e22dc792122b1f0171f34ade02725630dc884c3e2d4418ed4bfbd2ed4e39a4915645c0d5e32e90bb54bba74697 SHA512 5353243074d60b0c28a2b193ae1ecdff208aaffec0a76014768a54114048000516bcc78404912ed2e6e10276ef16193950c701688bd4ea4945176a726edeaa98
+MISC metadata.xml 530 BLAKE2B 46d64e0eda7d2d5f8001dfe42f9036a96ba8ca0da9a6a3a535407c91bff68adc559144b0937b9d37b08630e69de46402dd3728b73099e7ade1ece8a710ef9a63 SHA512 939a42e5c9eca1901749e5ab2242cdd375df94cc85a68076825023a4bd48d7866400023b74d2ae7271d638bb706155cebb049b9e190aed0b286055937b9f8aa4
diff --git a/dev-python/astrodendro/astrodendro-0.2.0.ebuild b/dev-python/astrodendro/astrodendro-0.2.0.ebuild
new file mode 100644
index 000000000000..17f262279441
--- /dev/null
+++ b/dev-python/astrodendro/astrodendro-0.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils virtualx
+
+DESCRIPTION="Python package for computation of astronomical dendrograms"
+HOMEPAGE="http://www.dendrograms.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astrodendro/metadata.xml b/dev-python/astrodendro/metadata.xml
new file mode 100644
index 000000000000..ea17c673072e
--- /dev/null
+++ b/dev-python/astrodendro/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The astrodendro package provides an easy way to compute
+ dendrograms of observed or simulated Astronomical data in Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astrodendro</remote-id>
+ </upstream>
+</pkgmetadata>