summaryrefslogtreecommitdiff
path: root/dev-python/astroid/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /dev-python/astroid/files
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'dev-python/astroid/files')
-rw-r--r--dev-python/astroid/files/astroid-2.1.0-fix-tests.patch16
-rw-r--r--dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch12
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/astroid/files/astroid-2.1.0-fix-tests.patch b/dev-python/astroid/files/astroid-2.1.0-fix-tests.patch
new file mode 100644
index 000000000000..32e75225507b
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.1.0-fix-tests.patch
@@ -0,0 +1,16 @@
+typed_ast doesn't support py37 yet and disables its support under py37.
+However, when dev-python/types-ast is installed, the test suite mistakenly
+thinks that it has to test typed_ast-related things and fails.
+diff --git a/astroid/tests/unittest_nodes.py b/astroid/tests/unittest_nodes.py
+index 56b195c2..762f1af2 100644
+--- a/astroid/tests/unittest_nodes.py
++++ b/astroid/tests/unittest_nodes.py
+@@ -49,6 +49,8 @@ try:
+ except ImportError:
+ HAS_TYPED_AST = False
+
++if sys.version_info[:2] >= (3, 7):
++ HAS_TYPED_AST = False
+
+ class AsStringTest(resources.SysPathSetup, unittest.TestCase):
+ def test_tuple_as_string(self):
diff --git a/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
new file mode 100644
index 000000000000..94eda1725457
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.1.0-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 2ad90aac..4628a40f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -42,7 +42,6 @@ def install():
+ install_requires = install_requires,
+ extras_require=extras_require,
+ packages=find_packages(exclude=['astroid.tests']) + ['astroid.brain'],
+- setup_requires=['pytest-runner'],
+ test_suite='test',
+ tests_require=['pytest'],
+ )