summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /dev-python/astroid
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-1.6.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index ba18c7520f1f..30380edea825 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,5 +1,7 @@
DIST astroid-1.4.8.tar.gz 184091 BLAKE2B 7180b98c757c8681dd0abaed1e79d2c58ce676aff07b539af8776d589ff23770335d0ba4ce5c9b3940b0428dd10174e7c6eff66aeb500e6ac561734e27975be0 SHA512 54bb20edf5518b417470a2d63210802b267fe727f9d30e1ac5000db00a7894739b1c4249468fb55df81b55d382f3a5bbe019876141f7ee4d94040fd699dc0c2c
DIST astroid-1.5.3.tar.gz 240617 BLAKE2B 06b040fa83327a38ea23e4b09c4ae978b5953ac99a7fec4b7fabb8982e8bb8da3e2f4781654159aec9989b4c99a119e1116622fa75bd4cac63d6a5c8b34bbf31 SHA512 2a224d9bf8e41059a1316d80738cdc0f1e4c4e0f987baf3969710bae7192466b708c7942cd7e4eeccea55582ce70bb687c96b9e7dece3229ae4cffc558aa2319
+DIST astroid-1.6.0.tar.gz 255715 BLAKE2B 60fa855779428fb984eb450afd1e6869a98f82fb06786194993a5f4c878f25417cb91ef2c2cdc12da62cbfa68e2742f8ac29cbc7b7ef295ed60201c72b562668 SHA512 6a384b2bd3b4ee686c2f9a69d10f4391e5950869d75808312b2715a620ba7caa706bd88a5e021ea2250cf16ff8013cf0b332faee0b07dd7b5e1baf11e65d0ac3
EBUILD astroid-1.4.8.ebuild 1096 BLAKE2B 8cc82d7263e7cc798609783f06f5255094dbd7712ee23441f975022282bc2eb0b9fe88ab727132b6f9689af2c530c60c480cdbd9cbf4f88f8005aaf692374565 SHA512 149b74ed93283dd9ace74311b313e93ad200e08c5056135c69da7117770361e7f0d958d309c482e8ef580665d4fc4c0ca41113deaabdd119c1df33904ce471b4
EBUILD astroid-1.5.3.ebuild 1662 BLAKE2B 9894a6a51d2d91b9474039af442049bc4863c3c41231eeec55da02741c6602d366a769c051c22a10c7b6a32dacfaeca2bd803e01df8b4b1c22db2ddd69996ba5 SHA512 0b6b2716cce18d524a1b5a656246ef5e0f83e451ea3e1f21a649392bcc7aa9e45e005b0e3a733a40844afa7d299507b4fdf3b99f0cd52cf2fc133b346699d4f0
+EBUILD astroid-1.6.0.ebuild 1942 BLAKE2B 9f2ba952f950e11b7c3fed67fa4846856573cefc380d7fdc76915b0804914b21090d4f25cb3371d28e0db5519ad566abd0c44c268d824ab8bab467b3804088c1 SHA512 0108724afeffe098fef70763b0fb80e6fe386f01e976ac11ad3e77f0b140d7b26fb30531eca3748217e2486d7aa1728bcc0fa90200a92c0f3057f89481390ff1
MISC metadata.xml 1122 BLAKE2B 29f5f5eb980aa5e9035316854d7b69a803bf8507cd8f2b97880ef3a0be3e200936ddc3679e480741cf82203b704cd6c7b1610d31e9173dc3f8b97ebec6a6c844 SHA512 34a45382d84c03057ba59b40905138c2e048da4d602e5a26dab4b156c1a3697369e11ef66f451f3f823ec827f3771eb58c077c056f9609e5b55a27841fd5bf9d
diff --git a/dev-python/astroid/astroid-1.6.0.ebuild b/dev-python/astroid/astroid-1.6.0.ebuild
new file mode 100644
index 000000000000..a9a7862bca13
--- /dev/null
+++ b/dev-python/astroid/astroid-1.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*')
+ >=dev-python/pylint-1.6.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable failing tests
+ # TODO: investigate if it's our fault and how can we fix it
+ sed -i -e "s/test_namespace_package_pth_support/_&/" \
+ astroid/tests/unittest_manager.py || die
+ # we hack xml module, so it does not match what they expect...
+ sed -i -e "s/test_module_model/_&/" \
+ astroid/tests/unittest_object_model.py || die
+
+ # no idea why this test fails
+ sed -i -e "s/test_namespace_and_file_mismatch/_&/" \
+ astroid/tests/unittest_manager.py || die
+
+ # and this test works yet it shouldn't
+ sed -i -e "s#test_object_dunder_new_is_inferred_if_decorator#_&#" \
+ astroid/tests/unittest_inference.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
+}