summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 01:26:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 01:26:11 +0100
commit4e6c4afbf915139e378349649c943e7df6b21efa (patch)
tree2c0b5352415b47b9bca8386f0ed9c80469c84625 /dev-python/astroid
parent9a00e0f54566977800de42e80dd91409ef26bcb2 (diff)
gentoo auto-resync : 10:07:2022 - 01:26:11
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.12.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 42b73d327cc2..a6b39d1cb653 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,5 +1,7 @@
DIST astroid-2.11.5.tar.gz 414503 BLAKE2B 3bdd93c8c958dc8ede9b5c4b0d01399578c1c8824c511aa6697e6653ef6caec2e2597a862e03a72fc0dc6d0bc63d327a0cf4b62b9632604e9b8485f84512b5b2 SHA512 6b6d1e35b95c68d7219534ceda6e2802cc6f2d9cd9bed6a880eaf0937dfb288d9fb58dac9be33072f4676a568f778eb26a78f447d4a44842a98d8677e151e1bb
DIST astroid-2.11.6.gh.tar.gz 414842 BLAKE2B 3300037aad912be25d99cc20576f472b907c064c2cb434d9a40a9014df44749760cd8921411f3abdf8e08bd08e612cf6aec13d73ca38ec8ac31cd1ed007282bb SHA512 2276385d74d9bbfd0d99c786d2598105161b2c71c96ca73183b6e2672f8b61c31667c337a1d3967956ef5fdbb54392d604a84da5ac456354d04fb4ad37b11f61
+DIST astroid-2.12.0.gh.tar.gz 429498 BLAKE2B 4daf36a96c1f47446558ef223210becd78db1ee8dc76247f9e8d4c16622f777cd9f5d70ed863de9f893b9427b479057f72f24c4c8c7b1468c566eda85ee829b0 SHA512 3a5a104a98268f61bf852f7565ef7a4f3d6ded4e8cfa0a6d5dea08e045d3fc0067633618311d82fc2f330e56ffd11d02a81c2493222eeffadf2d333b24b5aa58
EBUILD astroid-2.11.5.ebuild 1783 BLAKE2B a1006a85d74f9412adcb9f57ab080b616e8e4dd33968c8c9aa0f4fc0402970eb2b21c1111f96302b41fa506357154e4c759429de4595d2547827f8874b7d477a SHA512 c5864ee70ddb96a53101bd4e759c1f5c3865be6c1c1d64fdd3c9d2959b5b6269b43d905c67359aeb0dc534ad22ef6556648af0ba93ca8c497abd014f56d846c7
EBUILD astroid-2.11.6.ebuild 1794 BLAKE2B 79d94a97b10cc1410cbe8da6ca6b44f484fefb712a630bd7dde7d52f7c25cb4247d3e60594d605ec4844dbe210acbb59b19fefef51bc5b6609fbb0fcd3a8e2c2 SHA512 1273a20a8750416d73a5294131967c24c85ea0f2f017da9b0f07f712c311e82c74d8b65f9de65325f0cfbe84ae2364985a751b8dd72de51072b8ea2dd12d1ef3
+EBUILD astroid-2.12.0.ebuild 1816 BLAKE2B a01fa3bf6df8cf612e145178e7f6925223f38b51895bb3a5bcfe9032887de8b86fd57cecca439a1b2ae86a8bdcb542bb9932b6045979425bc39a1aea69797eb1 SHA512 6ab8b78285f781ced5cb70973f6a11d80db11acbe25f37941ca58014cf6d27f593d7fdb1a7a1497417af8c0fdf0b6c79e970e834e0be5f5c4eaaae2994d4ec43
MISC metadata.xml 1143 BLAKE2B 1f6c4e004277eebed2e29cb935ef01e5f18fb0a526f99f0e875ae3815308dce0483b5274b4e23bed076464aa62a035937a7a3817e2d4a5fb9211b9043271e04c SHA512 56b07d0f08a49772661bc3d233cf1f628aa7c241c51b91d75dfbd44995e169d8ab5bbd99863d7b9b67792486346982a7b8eebefb462e7e212cd7dff920d80840
diff --git a/dev-python/astroid/astroid-2.12.0.ebuild b/dev-python/astroid/astroid-2.12.0.ebuild
new file mode 100644
index 000000000000..de2148b20e43
--- /dev/null
+++ b/dev-python/astroid/astroid-2.12.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/unittest_brain_dataclasses.py::test_pydantic_field
+ tests/unittest_brain.py::SixBrainTest::test_from_imports
+ tests/unittest_regrtest.py::NonRegressionTests::test_numpy_distutils
+ # some problem with warnings (our options?)
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/unittest_scoped_nodes.py::test_deprecation_of_doc_attribute
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}