summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-12 06:07:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-12 06:07:09 +0100
commit6766ae9a4205bc53227127a1dd518ea601246afe (patch)
tree0717a1249b6c0340842b8f5cf78a3774ef985043 /dev-python/astroid
parent4658e9ebb16790a76f119b3c702097e068bd60f3 (diff)
gentoo auto-resync : 12:08:2023 - 06:07:08
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.15.5.ebuild65
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 7be2575ced45..008bd401b429 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,5 +1,3 @@
-DIST astroid-2.15.5.gh.tar.gz 461755 BLAKE2B 4af28becb14d767c3fa162be93cd1d3f99e42a476a7b1ee57225a6d5603876cbfde7a58e17412d1142baa42288cbb2cfe3ecdbaafe5195c777f04a3ad9fe4427 SHA512 9862a2f4703b36284d14a3b09f80b4b0a1e0948e306b4906ec663fc133d07966e24a711a90067b369b166ce4d53859327e1da84406a023d1a911fff7bb0ed026
DIST astroid-2.15.6.gh.tar.gz 462156 BLAKE2B f5df204a0b635d29165da1566afd9259ff26102fef3b56685ad9e10fe1cdae35aa90b1e1f81293e591c03122e980936dfd91b521dfe7a4c8cfacb8b40bcac9d6 SHA512 20c4d316176b84d61b5f44823026926e84c7de3c3a6febaa23cf9c8c5a9507ce65168804a61cb2db0ffcc7ec0ecb687282e6c794485135203cc25d30064e0047
-EBUILD astroid-2.15.5.ebuild 2056 BLAKE2B 84fa5ec7453a6d38e3fa2ee8064322d0e2db5b739814ab33ac71f83a6d1ea7ee61ff909ebd1ccb7ccbb8729ce95223d1d7cdd94c38d0e4f252a1274161d07277 SHA512 913d03026a52671360116f2e29386207470ec68eee96273117ef4f17c46f5d537cdf3b1120181ac6d8c4db22ade9f6ead702f253419ade69f7241e6d0fb70d88
EBUILD astroid-2.15.6.ebuild 2128 BLAKE2B 01f6d4c0ad79f509c1a83768c95600d88c664deba854d6918ba1fa0af5872bd31fd6529f242d2b04423b83d852016bec866fb97be54b823ac3b97b067ee48854 SHA512 57cd191f718ddf5e0e90b8781b2eca9b6c91dca1821b1a95763e0b574a645ab6c5cdbfa91ea202a194799cc52d697b534d01786e9d98302dd85ce79d8dc5576e
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-2.15.5.ebuild b/dev-python/astroid/astroid-2.15.5.ebuild
deleted file mode 100644
index c256f24264b0..000000000000
--- a/dev-python/astroid/astroid-2.15.5.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/pylint-dev/astroid/
- https://pypi.org/project/astroid/
-"
-SRC_URI="
- https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# Version specified in pyproject.toml
-RDEPEND="
- >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- <dev-python/wrapt-2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # no clue why they're broken
- tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
- tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
- # some problem with warnings (our options?)
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
- tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
- # requires six bundled in urllib3, sigh
- tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
- # requires pip, and looks suspicious anyway
- tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
- )
-
- # Faker causes sys.path_importer_cache keys to be overwritten
- # with PosixPaths
- epytest -p no:faker
-}