summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/astroid
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest3
-rw-r--r--dev-python/astroid/astroid-2.4.2.ebuild53
-rw-r--r--dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch21
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 5289e1c42b14..4e1e6d181aed 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,4 +1,7 @@
AUX astroid-2.3.3-no-pytest-runner.patch 405 BLAKE2B dc496ac27938fa316f59f3058a8f2f17ca397225ae09a1adde80c8da50cd68572052a733ff08d5fcc602d3c38722a16f3f8395608955d9b56c8f1c122541c4fb SHA512 be925b49c4ef04f9b554e446410904dca1529a8aa61a8fe9ca869e1c1a177ca86e7632c62c0f1025caa69e58ce23ff7f342198ba9fb85ec1bde164fb63e285d0
+AUX astroid-2.4.2-no-pytest-runner.patch 643 BLAKE2B 830b0d604e988701faf6c75f148ff65775bbd349ab11669ff9e50809541d45af5a575f5d8874e4260f2e300ffac2446a1f9469da21ab288f325693eebc67f5b7 SHA512 3b2819eda0bdf0847aa7153439dd2cd766aa588921f8c7acf6da85a966ba7047e19a508a208141f7be11fc3348a7757d23a1c0835e977a9fe545cbafec09eb3d
DIST astroid-2.3.3.tar.gz 297350 BLAKE2B 7ac5cf028fa0263998271d23128b1bfd127fedafab2f6b3cc465867b9668942e1edc79bed62eb34bcce31b6892e4c5a31dbdd68d20fb92a1f134dc9e78a76920 SHA512 72011f3eb312ea7ce7dd55f7615972f6bfc152d8f16f9052b405f44fe17e594d5da22e0502b4c3034881b9783be9e808509d4ded3d679182ddf6d34eb90748f1
+DIST astroid-2.4.2.tar.gz 310972 BLAKE2B 23ebe5ef418ce19b64eb1c0f8d711c3f0d86ae32cff112d9a99db48d20a34c73cfa97c96229fd0f0f1169720d24e2cfd0b5a327c29ea0fc0f54a57ede45fcebe SHA512 f5d759c07a13e06d3d071faacff2dc775924566aaef8bdb6e526c4ebf723b6b561f5824b711b33e33a2a69df0a2ff4cbf0f4302c9a0d55610e031e81c4a4be91
EBUILD astroid-2.3.3-r2.ebuild 1419 BLAKE2B 58a8ff2ac83e43c980dbd1cccfc2addf994817267c94fbb12dc33cc8fce57f49e42af5ea934c4e2c92273b82ce181a37b602a3047da2392a586c8c5ccc509c17 SHA512 0f28599a319172926d3c522bc75fdad347a4e77e943d898dd797e9f08844b1e1beff1395c8eb2231338df3a1fe6a90dc81500513c52340cade63dfd376f717ec
+EBUILD astroid-2.4.2.ebuild 1359 BLAKE2B 851eca202c7deaaca203ffc977104ba7d27c2a409dcabae463679534293d8d8bb229c308cdaafadb1de5979d8398e1e289e27317e480f0c2c7bec77fe4fa8f6a SHA512 38b6f3b8ceb719ef3ae0e12e770fba60d8fcd593fe038ee2101270f0452a175e9c07341d45f23258eb66881e783b58b43d9e815dbbe8bbe812be20adfe5b886d
MISC metadata.xml 1147 BLAKE2B 6fd688ecaf19f5de658caecd0e4a5b5b451ece67b0e55afc8fc65cae8f99f0a2cb09c5e70b2cf3b68a4748ee10a417dfcd93569cc35e866aec7404d6ec9ecac4 SHA512 5eab195b147e8e1551871f537d61d0a4460ff8be0420c7e1661f6774f7fe8ace43f665f64d61677bdf890788d8a53206ac54350a8c6b73f87ba9a6edd44d56da
diff --git a/dev-python/astroid/astroid-2.4.2.ebuild b/dev-python/astroid/astroid-2.4.2.ebuild
new file mode 100644
index 000000000000..4b6254b039d1
--- /dev/null
+++ b/dev-python/astroid/astroid-2.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.2-no-pytest-runner.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable failing tests
+
+ sed -r -e 's:"(wrapt|six|lazy_object_proxy)(~|=)=.+":"\1":' \
+ -i astroid/__pkginfo__.py || die
+
+ # no idea why this test fails
+ sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
+ tests/unittest_modutils.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch
new file mode 100644
index 000000000000..cae04e05a33c
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index 016fce18..a6825d8b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,8 +30,6 @@ with open(os.path.join(astroid_dir, "README.rst")) as fobj:
+
+
+ needs_pytest = set(["pytest", "test", "ptr"]).intersection(sys.argv)
+-pytest_runner = ["pytest-runner"] if needs_pytest else []
+-
+
+ def install():
+ return setup(
+@@ -48,7 +46,6 @@ def install():
+ install_requires=install_requires,
+ extras_require=extras_require,
+ packages=find_packages(exclude=["tests"]) + ["astroid.brain"],
+- setup_requires=pytest_runner,
+ test_suite="test",
+ tests_require=["pytest"],
+ )