summaryrefslogtreecommitdiff
path: root/dev-python/astroml-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/astroml-addons
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/astroml-addons')
-rw-r--r--dev-python/astroml-addons/Manifest3
-rw-r--r--dev-python/astroml-addons/astroml-addons-0.2.2.ebuild28
-rw-r--r--dev-python/astroml-addons/metadata.xml23
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/astroml-addons/Manifest b/dev-python/astroml-addons/Manifest
new file mode 100644
index 000000000000..4d4526fd73f7
--- /dev/null
+++ b/dev-python/astroml-addons/Manifest
@@ -0,0 +1,3 @@
+DIST astroML_addons-0.2.2.tar.gz 51052 BLAKE2B 82b1933d335096f85d311fff8e252a4c36ce56922084c8ffdc01535cee3529c705627ff986d1bfdb60a8b9679db5042a1511a17adf93860509a47aad2660efe9 SHA512 97c61c731d3dd8cadbfcb36defd1a678f776a2012fda1159621d3e364e25ca74cd0d284980f52095a2df31973cefba09f9b3efe72ba95b4f65ca13e4aaec5e20
+EBUILD astroml-addons-0.2.2.ebuild 644 BLAKE2B 086712f80448e79b24524d345816683a917e93519aba5b2d7cef65eb8a7e8c729677addd4f018c283c9c3d46b1c5ccb47934d4891277413647d5836c4dae2c20 SHA512 bd2b3cb1437b21e7a6f2005f51be62438259984ddbaef614b38b8f51934444723820414f890f7dc640e93c6122fcf0de881147ce22908052b32610bc5a65a0e9
+MISC metadata.xml 1161 BLAKE2B 4d6ea9a526f2a8a9283557dbd1c9fb350480dea5df19f16cc8f0494faecf077a749046bebef738ee6c5d579ece0b1aabc4c869d0711fdd0fa64711ea8fc6689f SHA512 3010f13652915ec0a1daca8a0bf090e7e9e7522485080492b3fd932b2154752d56c95a586ec693bca1f6c6062e8c49e35336daf987b9119c5c97c1a8350f64e4
diff --git a/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
new file mode 100644
index 000000000000..ad62cb49a4a2
--- /dev/null
+++ b/dev-python/astroml-addons/astroml-addons-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MYPN=astroML_addons
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Performance add-ons for the astroML package"
+HOMEPAGE="https://github.com/astroML/astroML_addons"
+SRC_URI="mirror://pypi/${PN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/astroml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+DOCS=( README.rst )
diff --git a/dev-python/astroml-addons/metadata.xml b/dev-python/astroml-addons/metadata.xml
new file mode 100644
index 000000000000..c9e92bac1f13
--- /dev/null
+++ b/dev-python/astroml-addons/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ astroML is split into two components. The core astroML library is written
+ in python only, and is designed to be very easy to install for any users,
+ even those who don't have a working C or fortran compiler. A companion library,
+ astroML_addons, can be optionally installed for increased performance on
+ certain algorithms. Every algorithm in astroML_addons has a pure python
+ counterpart in the core astroML implementation, but the astroML_addons library
+ contains faster and more efficient implementations in compiled code.
+ Furthermore, if astroML_addons is installed on your system, the core astroML
+ library will import and use the faster routines by default.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astroML_addons</remote-id>
+ <remote-id type="github">astroML/astroML_addons</remote-id>
+ </upstream>
+</pkgmetadata>