summaryrefslogtreecommitdiff
path: root/dev-python/astroplan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/astroplan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/astroplan')
-rw-r--r--dev-python/astroplan/Manifest6
-rw-r--r--dev-python/astroplan/astroplan-0.2.1.ebuild56
-rw-r--r--dev-python/astroplan/astroplan-0.2.ebuild56
-rw-r--r--dev-python/astroplan/files/astroplan-0.2-ephem-import.patch11
-rw-r--r--dev-python/astroplan/metadata.xml16
5 files changed, 145 insertions, 0 deletions
diff --git a/dev-python/astroplan/Manifest b/dev-python/astroplan/Manifest
new file mode 100644
index 000000000000..3f997b36b1d6
--- /dev/null
+++ b/dev-python/astroplan/Manifest
@@ -0,0 +1,6 @@
+AUX astroplan-0.2-ephem-import.patch 505 BLAKE2B f8cf17ff9725dbf756ffce538225fa893c2122bf249001b4631549dd2663cd24eef988bc33456477ccdb2ed9250636397758db1c90bb2bcae1179dcd5e82e73e SHA512 9ea80ff153f9da458d377eb99fefa5f0dfdf448af196150e47bd19d3c5071f975b7746c6fe91c0042e92b3349a44d7c0843025d8069084bd779ebdb7160f0d74
+DIST astroplan-0.2.1.tar.gz 270482 BLAKE2B fd0d83e492a46c711b32899d6cbb93fac1708588028e8a0c72c76fa13bfdf9db3bea135a09d801deea0a7a67b114c9d8b7f8af5a642348303a392240cdc76363 SHA512 baa585ce2b651753b45c6bda78a93b22340b380197338ce3d27d36509c82c29053da237f1f1daf5c12ba08e0da27f7c3cc98daebedb703c944a3e225444f3aff
+DIST astroplan-0.2.tar.gz 264623 BLAKE2B 4343334ef12a13d3269a35403c89eb5c5b124de5f30e9512dce9ba47f1f1ee490e9caf7c7c8511f027eeddae33e2732bb2bad6722ec8b7dfb348aa586c905dfb SHA512 ab98402d2b0daf64aea4a10934c8e33097b92d3b7de9a2346fa3e318e672c85966c050f560bb3fc4c247e2fdd4c94a4b158d6a0dff6af9c83d6411613c663bd9
+EBUILD astroplan-0.2.1.ebuild 1475 BLAKE2B a8c7c8176b75c7c5d18da78d11ac54a36e73b90fcd8d57abbca438554b4512d0d2a4c789954e3736bbb11c2fe9669734ddf675e99f23146c711bda3f6b196a7c SHA512 3ca8b8adab62180568c7a45bdc18b9bc38c0286384cc6bfbd214e2a6b31fb30c0b96456eb2272a1878fef74009fa81ef9684d9c690dae7c8577e46489ef29598
+EBUILD astroplan-0.2.ebuild 1466 BLAKE2B b3eff7363bfd6930e92125c022915aff91805972b50d4089c5eec2cafb1891333c16aa8a7d67431e9a6720d3fadf7d3fc27281eece58633970c35bfd8b83ee45 SHA512 09e98ddf77eb2d54edf399ebe711d0fcc87b85b19be63a162b467336e623b9a7e1880c25d3a73632fd512fb8da3c8edd308f057351e2750c2b5108a4f137c8f5
+MISC metadata.xml 580 BLAKE2B 4874e04355b1b3ee9b09fe0f55030436c8e538ea3a7727ce389879fec76e03b7285eb776d1b2c182dac19a1dac29f40c8f414f3eef0e4e4b505681507459ec15 SHA512 16cb9da0545ab48966ee589d6f6ed9dbf011efbecf5eeddd3cbca35d1369ea35fe7dee7cf89ea735ca83058b1e2ab8232d2f404cba35d100798fdcc0ab46a083
diff --git a/dev-python/astroplan/astroplan-0.2.1.ebuild b/dev-python/astroplan/astroplan-0.2.1.ebuild
new file mode 100644
index 000000000000..9ed8a4959bf3
--- /dev/null
+++ b/dev-python/astroplan/astroplan-0.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Observation planning package for astronomers"
+HOMEPAGE="https://astroplan.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2-ephem-import.patch )
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ echo 'backend: Agg' > "${WORKDIR}"/matplotlibrc || die
+ MATPLOTLIBRC="${WORKDIR}" virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astroplan/astroplan-0.2.ebuild b/dev-python/astroplan/astroplan-0.2.ebuild
new file mode 100644
index 000000000000..83166f96c41b
--- /dev/null
+++ b/dev-python/astroplan/astroplan-0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Observation planning package for astronomers"
+HOMEPAGE="https://astroplan.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-ephem-import.patch )
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ echo 'backend: Agg' > "${WORKDIR}"/matplotlibrc || die
+ MATPLOTLIBRC="${WORKDIR}" virtx esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astroplan/files/astroplan-0.2-ephem-import.patch b/dev-python/astroplan/files/astroplan-0.2-ephem-import.patch
new file mode 100644
index 000000000000..59328290c07f
--- /dev/null
+++ b/dev-python/astroplan/files/astroplan-0.2-ephem-import.patch
@@ -0,0 +1,11 @@
+--- a/astroplan/conftest.py.orig 2016-11-30 23:17:49.057492656 +0000
++++ b/astroplan/conftest.py 2016-11-30 23:18:11.076451659 +0000
+@@ -38,7 +38,7 @@
+ try:
+ PYTEST_HEADER_MODULES['Astropy'] = 'astropy'
+ PYTEST_HEADER_MODULES['pytz'] = 'pytz'
+- PYTEST_HEADER_MODULES['pyephem'] = 'pyephem'
++ PYTEST_HEADER_MODULES['pyephem'] = 'ephem'
+ PYTEST_HEADER_MODULES['matplotlib'] = 'matplotlib'
+ PYTEST_HEADER_MODULES['nose'] = 'nose'
+ PYTEST_HEADER_MODULES['pytest-mpl'] = 'pytest_mpl'
diff --git a/dev-python/astroplan/metadata.xml b/dev-python/astroplan/metadata.xml
new file mode 100644
index 000000000000..b320e5789d60
--- /dev/null
+++ b/dev-python/astroplan/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Astroplan is an observation planning package for astronomers that can help
+ you plan for everything but the clouds.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">astroplan</remote-id>
+ <remote-id type="github">astropy/astroplan</remote-id>
+ </upstream>
+</pkgmetadata>