summaryrefslogtreecommitdiff
path: root/dev-python/async-lru/async-lru-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
commit171d09fa1f429aa43835c618a2c21753ad5209a4 (patch)
tree7a9f3e0ed5e5a7dbabf98c971e8202b7ce50035b /dev-python/async-lru/async-lru-2.0.2.ebuild
parent1826a30af36ae674cb71400eacaf0a0762df510f (diff)
gentoo auto-resync : 21:02:2023 - 14:24:25
Diffstat (limited to 'dev-python/async-lru/async-lru-2.0.2.ebuild')
-rw-r--r--dev-python/async-lru/async-lru-2.0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/async-lru/async-lru-2.0.2.ebuild b/dev-python/async-lru/async-lru-2.0.2.ebuild
new file mode 100644
index 000000000000..a248775df733
--- /dev/null
+++ b/dev-python/async-lru/async-lru-2.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cache-clear::' \
+ -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+
+ distutils-r1_src_prepare
+}