summaryrefslogtreecommitdiff
path: root/dev-python/async-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/async-timeout
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/async-timeout')
-rw-r--r--dev-python/async-timeout/Manifest3
-rw-r--r--dev-python/async-timeout/async-timeout-4.0.2-r1.ebuild39
-rw-r--r--dev-python/async-timeout/metadata.xml15
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/async-timeout/Manifest b/dev-python/async-timeout/Manifest
new file mode 100644
index 000000000000..d2bf233ab440
--- /dev/null
+++ b/dev-python/async-timeout/Manifest
@@ -0,0 +1,3 @@
+DIST async-timeout-4.0.2.tar.gz 8221 BLAKE2B ebcb2ef956590e265bbdecc223a877e7260750aecf5b631c6af1f335ce57b51579467901e2344bfa8495010eb1e6e7a39adfd4b6311483d63e0674221888d1f7 SHA512 e9884a525b99bc1a3a15c958a1dbb25a92cb286bb7360b03b0be3198e61685970628c8fef6dc478beba3f031e0ff6f03b1fcc3c2c34032d7fea6f8b65850ac38
+EBUILD async-timeout-4.0.2-r1.ebuild 871 BLAKE2B c270a68ad1759cd4e4e2a807ef980733c07a39187c6d1ff99c88d0426ecfae406372fb8c0f013c2d91c4e160d2798bba2dc2451851e27414ebe274ea377b418e SHA512 84b6c8bb4cf4cb3192e352ce0a8b5fe7b18352bdca33bdd8481eb249ec6579309bfb6b86e976622f8f7dd347f3c71e42f4ba2bc3db8d4fae593163ac23934c0d
+MISC metadata.xml 460 BLAKE2B 33594e2b78abaae89f7cb0c953a432ead4c468e01d005d4a65aeb846030fa01b1544d8df393e9d73cc4af6e557f106f8077c3fc4b0b35aacec20033352564083 SHA512 47b1f783f49a63c17abcabcc73d350582297f5bdd266a3d57079f1a50e4a6e88680b73993d9efa3609fe9820decf7a4ea4b5b87f9db6e99509695286c50aab1c
diff --git a/dev-python/async-timeout/async-timeout-4.0.2-r1.ebuild b/dev-python/async-timeout/async-timeout-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..6276c3ea3c17
--- /dev/null
+++ b/dev-python/async-timeout/async-timeout-4.0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="
+ https://github.com/aio-libs/async-timeout/
+ https://pypi.org/project/async-timeout/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pointless dep on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -p no:aiohttp
+}
diff --git a/dev-python/async-timeout/metadata.xml b/dev-python/async-timeout/metadata.xml
new file mode 100644
index 000000000000..6a8fc4d6f012
--- /dev/null
+++ b/dev-python/async-timeout/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">async-timeout</remote-id>
+ <remote-id type="github">aio-libs/async-timeout</remote-id>
+ </upstream>
+</pkgmetadata>