summaryrefslogtreecommitdiff
path: root/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild')
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
new file mode 100644
index 000000000000..10f7da0d6a0d
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest