summaryrefslogtreecommitdiff
path: root/dev-python/attrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/attrs
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest4
-rw-r--r--dev-python/attrs/attrs-21.3.0.ebuild44
-rw-r--r--dev-python/attrs/attrs-21.4.0.ebuild33
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index d233389c7674..60c160ca50af 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,3 +1,7 @@
DIST attrs-21.2.0.tar.gz 184694 BLAKE2B 5c960f7c1a4623186c7a0cec8a9096df8df8e7d3022b67b281dcdd3a512ce6f105dfdd5ec10dc85a2b9971564f44e7b4474d760667e53cd2cf0f0543153eb6e2 SHA512 35863f599076357e40f72a62968f4a2f9bc2af9f59f484fef051be4f9730ce9e28e11568915d690ade7980df8998af22e2ff8b9568a205d7745e246ba5f3a7e1
+DIST attrs-21.3.0.tar.gz 204413 BLAKE2B 1aac1198196aa3438eb1ec9dac0a4971362caea655e27a2b7811e48d500a40fe8f2daf43ce86d3b381892763fdfecf9adbda16a29dda57155ec5a588732b423d SHA512 23b2ba52af809581e9907ad7c6d18ed050d415645a249ae912af3f1398276ea5bf67f11991d7958f3eeafe759d8d62a65009555ae8f75580cfa464c5b4a37742
+DIST attrs-21.4.0.tar.gz 201839 BLAKE2B f8e9ca1385efe6f5b9bf468f622f0bf5390830c5f3c3526821446113146a61460b17e8750ea763f6da50221a8aa65f5f1ff98a6ddf69b1a87344508ca6495560 SHA512 5a52776eb505c8a354912fa037a9710e49830fa6ad37272cb6d8c3298f4179a5b237e36cd7db3b1c9af19fbf0194ad6b83c3db9a473f9349769180073273ba65
EBUILD attrs-21.2.0.ebuild 834 BLAKE2B 8f0f084f77ecc36fa86224d54fed167f261f2d2849f93ed574e8515ab71ce90bff54378355a37a7d876e702d5108d41b2f443e10dd8dce89ece2e30449cc6076 SHA512 8d79750bd49caf82bdeb3bdb9c1b4fce1afab4edbb23de615838727ad7de97789241c9338a8db256c931b7821d6c46f43a8ad561f8f10bc76835648a04a92913
+EBUILD attrs-21.3.0.ebuild 1048 BLAKE2B 9e3f3c11a743404d979dd6ad872281cbcc8fc23f552c4fdf41b577daf9d96b77bb422d76a0b4318ae440b051c19eefd9fe5472b65fe6a859ad0f3f9b39c6559b SHA512 d0439deb44d9db9fb2a583b0d487f84ede35b614423e834616f17aac2a8ef9d79435f8b615d636cc2e23ebd588b6cf6a229db097fc35170809518580dea440e3
+EBUILD attrs-21.4.0.ebuild 845 BLAKE2B 0baf5eca97840f2e20cbac13711f897b9327cc6334803c3054da6efe2621a531cb02d4676dc24bc7d354b8e335f5d0ea7f5bd9b2c844c14a2acae52cc91073f7 SHA512 84c589dde0739a7a038e3acf6fff84034bff40381d5b2167a84411649e4df76e2c9ec684eb2736cf77d387ec520ef1b587910b23c81f86217b0a5ab707ecec85
MISC metadata.xml 521 BLAKE2B 566735fbcb7141b4e2bf3130847bdde2850c803d5fe981540f728273231484984e5ebf3fed549cf9485763a8d9b8d102ccf984660a34541286621341e8aea64d SHA512 1b4999c797e93fd228652d1b6bd52dfc1a5e7b0828d2e70cdcf8dc859641c2c15f5353e1b9cf1b1f19dee8af75c521b26e651a7f4709e7729425d7dcc45137f1
diff --git a/dev-python/attrs/attrs-21.3.0.ebuild b/dev-python/attrs/attrs-21.3.0.ebuild
new file mode 100644
index 000000000000..8dc809a5f01c
--- /dev/null
+++ b/dev-python/attrs/attrs-21.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ [[ ${EPYTHON} != python* ]] && EPYTEST_IGNORE+=(
+ # requires cloudpickle which relies on CPython implementation
+ # details
+ tests/test_3rd_party.py
+ )
+
+ epytest
+}
diff --git a/dev-python/attrs/attrs-21.4.0.ebuild b/dev-python/attrs/attrs-21.4.0.ebuild
new file mode 100644
index 000000000000..fc8c81c3faf6
--- /dev/null
+++ b/dev-python/attrs/attrs-21.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest