summaryrefslogtreecommitdiff
path: root/dev-python/attrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/attrs
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest3
-rw-r--r--dev-python/attrs/attrs-21.4.0-r1.ebuild56
-rw-r--r--dev-python/attrs/attrs-21.4.0.ebuild2
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 4cbe58621bdf..5cf256ac0d0c 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,3 +1,4 @@
DIST attrs-21.4.0.tar.gz 201839 BLAKE2B f8e9ca1385efe6f5b9bf468f622f0bf5390830c5f3c3526821446113146a61460b17e8750ea763f6da50221a8aa65f5f1ff98a6ddf69b1a87344508ca6495560 SHA512 5a52776eb505c8a354912fa037a9710e49830fa6ad37272cb6d8c3298f4179a5b237e36cd7db3b1c9af19fbf0194ad6b83c3db9a473f9349769180073273ba65
-EBUILD attrs-21.4.0.ebuild 930 BLAKE2B 48c6466216bf3eeeb12192723ded3f7b5c3e0b2a421196b2a9a7bfaf211f0ce3be77df0dafcfa38d2aa94812537256b1552fcc589c1758611d8bfb70406cd4a5 SHA512 5105ce669c86b2096b8e077b07e976bac20a85c438c1820062021ad6fc70b25431cf57867e45cee7b1c964858342b00037dbcfbf5645ac13a93108fb5ccd862f
+EBUILD attrs-21.4.0-r1.ebuild 1856 BLAKE2B 674c04a1d762a5ee6757d09f3e39a47e8749d1350655c3761ad84393875f46aead915edc0c8bf46bd062f10afa8dc9abe7830abd14bf70eee4fab18681b7dbe4 SHA512 991d8679150a0b27e597e65101658e7c6c0e1efcd2066a25f8c5d13584575b7fce6babcb4a41b858dc01294c8969de8018a2a2b6264a62a1c6f81004b5745d55
+EBUILD attrs-21.4.0.ebuild 937 BLAKE2B 54a0b6abab149eaec87c951f880250709a9a2a1b7016c5958b8fd1d0858e3c6c32bf59d0209dcad67004cf78c6f2be762493e19e0305971312d2e6c8b2cfe836 SHA512 f397ecd027ffb4a1ea0abd99dbf870618642e51f115bbcee3ce421ef14589ca5c7582b61362b1f848468cf79dd113f34f0614c418150482863aa06de9672275b
MISC metadata.xml 521 BLAKE2B 566735fbcb7141b4e2bf3130847bdde2850c803d5fe981540f728273231484984e5ebf3fed549cf9485763a8d9b8d102ccf984660a34541286621341e8aea64d SHA512 1b4999c797e93fd228652d1b6bd52dfc1a5e7b0828d2e70cdcf8dc859641c2c15f5353e1b9cf1b1f19dee8af75c521b26e651a7f4709e7729425d7dcc45137f1
diff --git a/dev-python/attrs/attrs-21.4.0-r1.ebuild b/dev-python/attrs/attrs-21.4.0-r1.ebuild
new file mode 100644
index 000000000000..ee58a8f99423
--- /dev/null
+++ b/dev-python/attrs/attrs-21.4.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # https://github.com/python-attrs/attrs/issues/907
+ tests/test_annotations.py::TestAnnotations::test_auto_attribs
+ tests/test_annotations.py::TestAnnotations::test_annotations_strings
+ 'tests/test_init_subclass.py::test_init_subclass_vanilla[True]'
+ tests/test_make.py::TestAutoDetect::test_detects_setstate_getstate
+ tests/test_slots.py::TestClosureCellRewriting::test_closure_cell_rewriting
+ tests/test_slots.py::TestClosureCellRewriting::test_inheritance
+ 'tests/test_slots.py::TestClosureCellRewriting::test_cls_static[True]'
+ tests/test_slots.py::TestPickle::test_no_getstate_setstate_for_dict_classes
+ tests/test_slots.py::TestPickle::test_no_getstate_setstate_if_option_false
+ tests/test_slots.py::test_slots_super_property_get_shurtcut
+ )
+
+ epytest
+}
diff --git a/dev-python/attrs/attrs-21.4.0.ebuild b/dev-python/attrs/attrs-21.4.0.ebuild
index e99fdc790a49..1f70e5e92f63 100644
--- a/dev-python/attrs/attrs-21.4.0.ebuild
+++ b/dev-python/attrs/attrs-21.4.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
RDEPEND="
dev-python/zope-interface[${PYTHON_USEDEP}]"