summaryrefslogtreecommitdiff
path: root/dev-python/attrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/attrs
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest4
-rw-r--r--dev-python/attrs/attrs-20.3.0_p20210222.ebuild34
-rw-r--r--dev-python/attrs/attrs-21.1.0.ebuild30
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index ad12a5dddab2..83db2d46ed21 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,3 +1,7 @@
+DIST attrs-03d3fc7a71fe770e1f86b9c3ad8588586e5ea63b.tar.gz 170688 BLAKE2B 1256cb115b3613929f9caf7f31907a51c9afdd5f6e0a10a172089e920d6604c41db3fb11726ab71a698b4ff9e6420e827d5ff25c4127ef7c6cf12536a66a9bb3 SHA512 3007f8c502c0bcd2481ffbbb00bec4ed677d1be9514e417670c4adb791dc67eee76b8a7c07a4a972cd4ece3291e2c996944bb1cdb282682086551cbd571a0011
DIST attrs-20.3.0.tar.gz 164523 BLAKE2B 66d2e038e485833f5033fbabe2ef9a6565e3f5f5e8530f2c70019e4f5bdfca51083ac6d0bbc9eb765f838070bc90e01db1c83ed6da113ced67300238e12b5f42 SHA512 640532c6b763fd96572e5d85e93c111bebc4c5e0ff9419fe92fb51280f03acb5f9f43339f57d30659e777d5578460675c60ec0a362f9ad433893e3624ce6a931
+DIST attrs-21.1.0.tar.gz 187841 BLAKE2B fa3c4294d5b4f01ec7a8903cfdeb2ad37a77ac6a3d37cca8e559226ff8c28be989128132c0cc8a08963b095f2dd1b279522f5fe93b0ad497a030a09291f1056d SHA512 32110d74fc578a94edd959868cec491f22b9f63637fea72522980e3c1894eaa7ca4fd3a4c0a3f9a8a6d10d9186e6f04c52a18b66698947efa13e0922d61e87be
EBUILD attrs-20.3.0.ebuild 833 BLAKE2B ce05df27f8e418a6bf0862c00136c5d7629714d67bc0eedcf064d449c031f6dbb1cd08b562ae4123cac790bd53dc3a4bf4f5586f5bc8b6ba6b08fed023249c9b SHA512 5080069c8c25c9fa7311b7882baf115f2f65820095545aa471e5b574fe41b86ac756f02c2c2afe41b25cb744ed5e990a132b18518e2b08e3e570058aa7e2e30e
+EBUILD attrs-20.3.0_p20210222.ebuild 991 BLAKE2B 50a53ee9050d38f8a3603cd3f0e81515c4ae82b94c07063a1c2a2c3bd6e2ecbed834d6347a3d7d8f292eba41540c9a906b5e136b9b56a62a3a54de5c2efcb457 SHA512 c732af0c18ac2da05389d493c9419a847e809ef7b34d538fd439419fe0a7a4c2839fe19772c62f8661820bdfc95f0469fee4c8f52513486182f1fe2599caefba
+EBUILD attrs-21.1.0.ebuild 842 BLAKE2B 4f6a9f503fd54f3cb9c8cbd131bd1ef06fbee8aaa425e1599cfe039163520c808eefbf4a5eec9c8574209c69f1c40fcdbb4d99c0e3a09a503d2c09fa5c985843 SHA512 4bf5878fa38487239e553d2e9e7f249f98934db5dcb2d497a6d2178acd12aaa967efe612730f2fdbaa562c981f125873ca27b4e5aba1ca73ee4d162b8b07f110
MISC metadata.xml 520 BLAKE2B 48d3940a42f60eaa0359e1095eebfed747fff50cbf51f3a7bf2f8c569340e7474a4e5b4ac98ef24ea2ac21c4ab77d6a04b9a0ba435578826f1c3e769e79d7435 SHA512 d1c5ca93d410b922d97a6dd6dda32f4c2d1c47ec686cadfb6bda0846a5b623cdfd09671eaa6ecfc29da0dfaedaa02eeeeda24bbf5e97b8aa2fcd6beaaba95177
diff --git a/dev-python/attrs/attrs-20.3.0_p20210222.ebuild b/dev-python/attrs/attrs-20.3.0_p20210222.ebuild
new file mode 100644
index 000000000000..33b6eb24790b
--- /dev/null
+++ b/dev-python/attrs/attrs-20.3.0_p20210222.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+EGIT_COMMIT=03d3fc7a71fe770e1f86b9c3ad8588586e5ea63b
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="
+ https://github.com/python-attrs/attrs/archive/${EGIT_COMMIT}.tar.gz
+ -> ${PN}-${EGIT_COMMIT}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/attrs/attrs-21.1.0.ebuild b/dev-python/attrs/attrs-21.1.0.ebuild
new file mode 100644
index 000000000000..ac6abdcf46ed
--- /dev/null
+++ b/dev-python/attrs/attrs-21.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest