summaryrefslogtreecommitdiff
path: root/dev-python/autobahn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-python/autobahn
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest2
-rw-r--r--dev-python/autobahn/autobahn-21.2.1.ebuild12
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 9e31194d4e38..56914826fca6 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -7,5 +7,5 @@ EBUILD autobahn-20.12.2.ebuild 3038 BLAKE2B 063b7a3996d586d09fc14f110f50e6d239c8
EBUILD autobahn-20.12.3.ebuild 3094 BLAKE2B 0a1435ef4d1e9d0f957377a751af0bc7e4486720b627c797cb290db2ad1570a4297d161e90c0f3aba34701b385c3486bcc2ceab9a6b798b5c3b82329766a2afd SHA512 3aa3276154faaddf3db0b615364a2c65cfd19f112beae9dee0fd83fd1963ab272a01be6bde878ae283c7e5489d55232209773978c4af5b250d379b6ecc2675a1
EBUILD autobahn-20.7.1.ebuild 2995 BLAKE2B b1a4536d3153fb71bf0c83d89bdab51beff8cafd9a3686791c8697d8d249505843fb9ea7059ebc5e0d299884731b472d9e6255b2c8e800378c0a12336151361c SHA512 b64c89beb8c60179b8fef2dd9fdfb69b32a1bab0adf5e39fa3982bffba9cb55d2cc046216ee29f1a2248b1b15002a6e1f5e1e48f19507385dbde7235427d5157
EBUILD autobahn-21.1.1.ebuild 3145 BLAKE2B 5f8844a8228ffbfac12b6c36e782f07707f62336fa9c098ece49f4d23d1ac934f9ee91ea26abfa662fddceb6ea5302912ac3f237d62bff674be3788279aa5f3e SHA512 c7515208af81cce17bd51d9f31da17335938777f0386e2c1ed205f809cfec54eb8ffc3407127c4b5d14578ec644abc14e62b93b52b57ff63132f4c094733c345
-EBUILD autobahn-21.2.1.ebuild 3107 BLAKE2B b2afd1c70300357794e0b6b1995c0efc7703e812c5a645078c9557402d9f5fc2db449e93ea909785a2ad1152ef6e4d32f54696bc2d6147a63d11be1d75cb473a SHA512 53b68d9879f4b7d68b36d6aef5f865f87189b9e969d3b5bd21b397de269db733c2aa9ea44fcc3c57985c58234a3a848dc0d6c150902a87da863eb55baa2299a9
+EBUILD autobahn-21.2.1.ebuild 3108 BLAKE2B ca119cad37f38de68e006a7e7947ee27e7fc2e7460a1e5f1cc292772ab93b3055e6915f6413f98f52d9d814bcab946f59f48085da833717572b17da17d052a41 SHA512 9a755eecb6e8c856f95f5867cb3144470352515a1641eb473ec9532b945c2bdb8d75fd6278bed8ca71551153518b5753d6cd0cb6cde9c14f07e5a131653db4d1
MISC metadata.xml 665 BLAKE2B 11ce0fe43744ff03c46a4e4b6b06733807a4674956dc885a3185bd353f0617841a6f6d1afbbc02c02b7e6718b5c0ccce69907920322e2966c8f7e9d1f63d6485 SHA512 9e154ce907c9868b86a70c4c2f6173e4fa8cc6e1f63380978d4a9c706f00316a9eda488fc39c32c5ea70f31a1a12187629665b590e79f64906ab982bf1401fbb
diff --git a/dev-python/autobahn/autobahn-21.2.1.ebuild b/dev-python/autobahn/autobahn-21.2.1.ebuild
index 8cc01e514d37..78281c5cf7a4 100644
--- a/dev-python/autobahn/autobahn-21.2.1.ebuild
+++ b/dev-python/autobahn/autobahn-21.2.1.ebuild
@@ -72,6 +72,11 @@ python_prepare_all() {
# remove xbr components
export AUTOBAHN_STRIP_XBR="True"
fi
+ # remove twisted plugin cache regen in setup.py
+ # to fix tinderbox sandbox issue
+ sed -e 's/# regenerate Twisted plugin cache/# DO NOT regenerate Twisted plugin cache in Gentoo\nexit()/' \
+ -i setup.py || die
+
distutils-r1_python_prepare_all
}
@@ -89,13 +94,6 @@ python_test() {
rm -r .pytest_cache || die
}
-python_install_all() {
- distutils-r1_python_install_all
-
- # delete the dropin.cache so we don't have collisions if it exists
- rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache > /dev/null
-}
-
pkg_postinst() {
python_foreach_impl twisted-regen-cache || die
}