summaryrefslogtreecommitdiff
path: root/dev-python/autopage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
commit7f1592d914f244f1c2ab9e4bf84c003131f6d3b8 (patch)
tree7bce2dbb6156f707d739cb9fc044116fe4325dd6 /dev-python/autopage
parent5a2a5572ac35843b9cd1c9369bd96e117647d24f (diff)
gentoo auto-resync : 16:10:2023 - 16:00:40
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/Manifest2
-rw-r--r--dev-python/autopage/autopage-0.5.2.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
index 19fd5dbee2db..577a5847ba03 100644
--- a/dev-python/autopage/Manifest
+++ b/dev-python/autopage/Manifest
@@ -1,3 +1,5 @@
DIST autopage-0.5.1.gh.tar.gz 21406 BLAKE2B 45d67443fa882d6f824ea71a8f9d20eb1ae789a271d84dc566a2535de631b5ce644aa28f51c5be1db818194e39628b6526ac087cd6eccc425132f15fafda10e9 SHA512 3d6e10c222566fd5f5e07e3247ebe19ce7ffe3b4baf9948741ee9a8aaafbefb0fcfaf4b26f0a4a6392615e73c7e8539c9bcbff1112a291c193c0b653f33e8657
+DIST autopage-0.5.2.gh.tar.gz 21904 BLAKE2B 73597326f6d22d4cac9c9969edc0e6fc23f555d149947aa3aa81529347928a3f9112e9fb15a3ad65e17274ed308fb6fe20810d8364415fe7e59ab1bd47411361 SHA512 68e76dd4c4f049785e226eae499be85139bf57c59fd2161f5bb9df66878541e39a3edc1806f42382bd2d9a922cbdace0d05b60366f72d9a39c31fc39eae05883
EBUILD autopage-0.5.1.ebuild 882 BLAKE2B 7d6316cc99a413fef24aac90ec20b50b00832ed82e4e69e47bd5fae1cbaed00e49a216b9b9fc58f2b16a123dc6d60be5ed28f1a42f3bdbd22c0c3363693cb607 SHA512 50d8a0875f6088cbf0de1ecef6ea39d46167ea343b293305c63ec3dd7f22b4ef7f6a738a0d72bce1787b3177de670c1943e616f5b6cfbae736211fae5839d286
+EBUILD autopage-0.5.2.ebuild 886 BLAKE2B fa829f72d2b018e36bd5dab65b38cff434e081e79972a36cdceb04ce7e941366d65d67d85a17c8a070d552bafe21772286d3f678596448bf02d843bb6a4c0787 SHA512 2a47e8f76c7405c2cfa729d9568d35396933e185829e254bd4ae93d5f0d30c7cfbc63acf77f29ae4f9b9f8304ad4aaee372b5ae2f49f3ed9b652b7bfd635c3d0
MISC metadata.xml 390 BLAKE2B 6be679e40e58985a6ad622fcb85f130bcc6b8039accd14243e6dcba458a0af721eaf9e7928bfe0d29f62477df6e437143865b68a61820b88dfd61a6e760992ea SHA512 3d76be1ae51467569281305138475733f9ce9b89b7d2a41f496c69bebd86e205019d1e75d1de22267d36aa2822ebe8bf94f5722d46ec27a8a79f349e38dad3b4
diff --git a/dev-python/autopage/autopage-0.5.2.ebuild b/dev-python/autopage/autopage-0.5.2.ebuild
new file mode 100644
index 000000000000..332528ed561f
--- /dev/null
+++ b/dev-python/autopage/autopage-0.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://github.com/zaneb/autopage/
+ https://pypi.org/project/autopage/
+"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -e 's/test_short_streaming_output/_&/' \
+ -e 's/test_interrupt_early/_&/' \
+ -i autopage/tests/test_end_to_end.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}