summaryrefslogtreecommitdiff
path: root/dev-python/aws-sam-translator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
commit469b5d8f31adfd054c5c493fc3df2f9c89c9fa00 (patch)
treef51c77713647680335a341aeb6c5a7fa019a000b /dev-python/aws-sam-translator
parent7d6f532c36268a2a8f53fa33c8e547c59702faa6 (diff)
gentoo auto-resync : 11:11:2022 - 15:30:13
Diffstat (limited to 'dev-python/aws-sam-translator')
-rw-r--r--dev-python/aws-sam-translator/Manifest2
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index cbb3b970ce81..de1ff324bfb9 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1,3 +1,5 @@
DIST aws-sam-translator-1.53.0.gh.tar.gz 1158682 BLAKE2B 4bc8430936a1b180dc04637e540ecad7eb82cd7a5da5254f2b823075878a03ad3e63422c183b365b0dad927bcdf063b8ab40984ab23abe1d91d8bc3c411aa2f1 SHA512 292259bf8d4002b72be51db0358673eee61fe368be5db15e7faff195baae8fa194bef882fd0f5a9b5c46379fe5f9593d101a212121da8d0636aca709dd087f05
+DIST aws-sam-translator-1.54.0.gh.tar.gz 1004760 BLAKE2B acb875f6f25c43d605dc1a2ee38bde66eacc8de85aaa8c3231ded77a9252e1d722a82724e2d8bb8016e1d8cb7bd188c7dcb76e50ac79af20109713160b90a891 SHA512 a8dbf74e983eab124cfab7627f64fb013a59340b77820a96c5654503956370aeca51a676508b688d2f1c96c1fb9586c7711f03af5ca68f680edbb19516007f4f
EBUILD aws-sam-translator-1.53.0.ebuild 2255 BLAKE2B 48a47eaf224f0cf84d7d2ee0aa3e3e7ec62844b593e6aa14f6b8b5dc1e46934294fc4454f1c2666dc5d4148a9403c499f3ae43a1d522f5e9a3df929b52613b3f SHA512 8454a7fc31df79581066a995cc7c323e52eb70b29e2c2f9766a4cccba444e910763a51eec5f3920601b7e3d8023807a7558e8e6e083435ff66a0dc3403df187c
+EBUILD aws-sam-translator-1.54.0.ebuild 2328 BLAKE2B d7bdc79b15e35bae70f07b178be76813a7fc9a96b2ed73b5fa0d138395a3a0d718785709dae915db2fa2d8ef18cd716261e56556e8d935a15006a125db96e7e8 SHA512 86c47ab5e015d2be0c5fe19d80aa2299a33521c6b9688df6065ed297a739a6e2e354e8a48f20f7e644e77ce7320b8c0f5b2bb62f05849a6af3da8a7f6ec0ab9e
MISC metadata.xml 603 BLAKE2B 89556267393186cf69a585c58efeb6fa599bfb42ef221bea955ea807a28edee89036a2ee0d0ca81ae55d96702a01b171b837754dabf38047ecc2789157bb7116 SHA512 106b6d241eadf7807dadf03329073703f8b51e7443eddc4db8752878b6dd84cc4357689cd4b796b3a083192e9d98eacbe9e7b8af0273160c7b89846e78230a88
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild
new file mode 100644
index 000000000000..307deef634c3
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.54.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/validator/test_validator_api.py::TestValidatorApi::test_errors_13_error_definitionuri
+ tests/unit/test_region_configuration.py::TestRegionConfiguration::test_is_service_supported_positive_4_ec2
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_success_one_app
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_throttling_doesnt_stop_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sleep_between_sar_checks
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_unexpected_sar_error_stops_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_and_on_after_transform_template::test_time_limit_exceeds_between_combined_sar_calls
+)
+
+python_prepare_all() {
+ # remove pytest-cov dependency
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}