summaryrefslogtreecommitdiff
path: root/dev-python/aws-sam-translator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/aws-sam-translator
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/aws-sam-translator')
-rw-r--r--dev-python/aws-sam-translator/Manifest1
-rw-r--r--dev-python/aws-sam-translator/aws-sam-translator-1.55.0-r1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/aws-sam-translator/Manifest b/dev-python/aws-sam-translator/Manifest
index a556fde00479..f11ab4f8eb10 100644
--- a/dev-python/aws-sam-translator/Manifest
+++ b/dev-python/aws-sam-translator/Manifest
@@ -1,3 +1,4 @@
DIST aws-sam-translator-1.55.0.gh.tar.gz 1006734 BLAKE2B 5fbfd8719ad605e0df7acd8ecb25ca681f5863e67e97b57624c470fa6e77bb431d7ff19f5e00a181120ea809019d93bd75416e46ba1424e8839f80c10002b30f SHA512 4d2f1e3458cb9d2014f73575946e863e1d74e7432e2aaf17128638d69d9f092b4d531224e45c2110b50103a1e7c4343fc0282ad38fe959cf45af4a0a2b4663aa
+EBUILD aws-sam-translator-1.55.0-r1.ebuild 2329 BLAKE2B 72ee4a1a4f4597fe66324dfd7c1487673cc9e5f473d0b6e8a77de6005565abea2adf0397faa72365489d9b6b29baedc6ff929e696e1444d462feb8bea1734f70 SHA512 90f3b478928003dc8fa89fa19095936883ffc3eeb2a5cd048157992843c3b1fc795718a99d420ed465a97cf69eb2b9573f723097c7854b82c1e90fae4b0defc9
EBUILD aws-sam-translator-1.55.0.ebuild 2326 BLAKE2B f46ce1c2570bf4e190101068149659afe602bc18fbd398384d8870783e814a6a89acc72bd2dcd3b11b6e1dc3fd1384705fba2b57dde9758ece1b414f8bc0d676 SHA512 f26422aafe8c66243f541acbc81d675e97732e79402006e119b0240e722b59ec0cabc8cbdb171a0e18ae91309c769be35ff29c2ec88b54bb9d44b2a84375a602
MISC metadata.xml 603 BLAKE2B 89556267393186cf69a585c58efeb6fa599bfb42ef221bea955ea807a28edee89036a2ee0d0ca81ae55d96702a01b171b837754dabf38047ecc2789157bb7116 SHA512 106b6d241eadf7807dadf03329073703f8b51e7443eddc4db8752878b6dd84cc4357689cd4b796b3a083192e9d98eacbe9e7b8af0273160c7b89846e78230a88
diff --git a/dev-python/aws-sam-translator/aws-sam-translator-1.55.0-r1.ebuild b/dev-python/aws-sam-translator/aws-sam-translator-1.55.0-r1.ebuild
new file mode 100644
index 000000000000..b753c394a2a7
--- /dev/null
+++ b/dev-python/aws-sam-translator/aws-sam-translator-1.55.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
+HOMEPAGE="
+ https://github.com/aws/serverless-application-model/
+ https://pypi.org/project/aws-sam-translator/
+"
+SRC_URI="
+ https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/serverless-application-model-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/boto3-2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.19.5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/validator/test_validator_api.py::TestValidatorApi::test_errors_13_error_definitionuri
+ tests/unit/test_region_configuration.py::TestRegionConfiguration::test_is_service_supported_positive_4_ec2
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_success_one_app
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sar_throttling_doesnt_stop_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_sleep_between_sar_checks
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_transform_template_translate::test_unexpected_sar_error_stops_processing
+ tests/plugins/application/test_serverless_app_plugin.py::TestServerlessAppPlugin_on_before_and_on_after_transform_template::test_time_limit_exceeds_between_combined_sar_calls
+)
+
+python_prepare_all() {
+ # remove pytest-cov dependency
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ # deps are installed by ebuild, don't try to reinstall them via pip
+ truncate --size=0 requirements/*.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}