summaryrefslogtreecommitdiff
path: root/dev-python/aws-xray-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 07:06:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 07:06:38 +0000
commita03bc69159ecc073f051ca2079848553a8e34664 (patch)
treeee5424e043dfb1fe51f12594640edff5846b796e /dev-python/aws-xray-sdk
parent905e7d07da40378586e71ece65bd962b0b00c578 (diff)
gentoo auto-resync : 07:03:2024 - 07:06:38
Diffstat (limited to 'dev-python/aws-xray-sdk')
-rw-r--r--dev-python/aws-xray-sdk/Manifest2
-rw-r--r--dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/aws-xray-sdk/Manifest b/dev-python/aws-xray-sdk/Manifest
index d3c80ac6a557..d349e5e1a089 100644
--- a/dev-python/aws-xray-sdk/Manifest
+++ b/dev-python/aws-xray-sdk/Manifest
@@ -1,3 +1,5 @@
DIST aws-xray-sdk-python-2.12.1.gh.tar.gz 275525 BLAKE2B 7aae0cc3d6b733ee80b553d087bd85d02329c7da3a8902cb428823af4a53d47a14089a274cfccdfb197a77370dcb71775e1d111bb76205a1f09f9b60a5c92967 SHA512 3c830cf81f353a2805b641bda3d38d72a1286d413e0cd087bfeac78bfe00e7853c19ddab96f18275e7fd95317c2a6650d5e4b287d63c1d3900b25414a525c3dc
+DIST aws-xray-sdk-python-2.13.0.gh.tar.gz 276162 BLAKE2B 60a8cf121139b5a704f47676a10534a7e9e5cbbcadc3a10e2f864f2d6baef8b0d8fe82ef9356d3e459d21628584ec98d4a89ad31b8d982dc8859d0cdb0240999 SHA512 c36907788a891a8adef94591172c53dcc0ebde5c0a3552154a313d93af66d50d88aa3422c1abeba89e629aa224beee5eb17e14f272ee312c76aa7f437fadb77c
EBUILD aws-xray-sdk-2.12.1.ebuild 2198 BLAKE2B a9003e4881d6e2a8926db2406cf0af8bafa3d065b938a5bab7af3f63af06e461947b33024a468bb5ffe32d77c0aea034a0bdf98e1a252799c39e7b612a9e73ec SHA512 b0aeef318148b297d68821b0b930d954cc5d3a4e68f3638baf9bab39daa4f163f6ac7cf18e1948b3b23b2a2cf75727e0fb0ef3fcdd23fd975a4194e0a7c4fe2b
+EBUILD aws-xray-sdk-2.13.0.ebuild 2472 BLAKE2B 09e56a090c8411a499452654fd0870ed1610240ca16251e490515e081bf814b0b78b98f92a2cd2767295bd88ff03bfc229260e1011a01c80ecbfcad583887c08 SHA512 c3f0bb52ede6137b859df6a7c01b19ddf4f027d96b315cefc14d682ab7dd15ec7ccc2415a9b529a697f46cda128b697b6267f089227a8e2f09c6b79a454cab5b
MISC metadata.xml 579 BLAKE2B 3f7aaed38bcceb97fb3597954ca9075ddf7a5718bcac69327be2b99d241c6d8cb0eefd369ca892c8d751703de9067c7eadf19f8c4445334ee8e4952b99fef69e SHA512 f3033cf16f60cae6727f80bd53944972f851579ffef8101cf6fda45e2575696183ec92ea8c994a77bbf3ffc8219be2ae2fae456faabe73a9896bcefddf3b5db5
diff --git a/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild b/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild
new file mode 100644
index 000000000000..ed7e4879a7b5
--- /dev/null
+++ b/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=aws-xray-sdk-python-${PV}
+DESCRIPTION="AWS X-Ray SDK for Python"
+HOMEPAGE="
+ https://github.com/aws/aws-xray-sdk-python/
+ https://pypi.org/project/aws-xray-sdk/
+"
+SRC_URI="
+ https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
+ local -x AWS_SECRET_ACCESS_KEY=fake_key
+ local -x AWS_ACCESS_KEY_ID=fake_id
+
+ local EPYTEST_DESELECT=(
+ # Internet access
+ tests/test_patcher.py::test_external_file
+ tests/test_patcher.py::test_external_module
+ tests/test_patcher.py::test_external_submodules_full
+ tests/test_patcher.py::test_external_submodules_ignores_file
+ tests/test_patcher.py::test_external_submodules_ignores_module
+ # benchmark
+ tests/test_local_sampling_benchmark.py
+ # Fails, probably because above is ignored
+ tests/test_async_local_storage.py::test_localstorage_isolation
+ tests/test_async_recorder.py::test_capture
+ tests/test_async_recorder.py::test_concurrent_calls
+ tests/test_async_recorder.py::test_async_context_managers
+ # connects to local mysqld
+ tests/ext/sqlalchemy_core/test_dburl.py::test_db_url_with_special_char
+ # TODO
+ tests/test_lambda_context.py::test_disable
+ tests/test_lambda_context.py::test_facade_segment_generation
+ tests/test_lambda_context.py::test_put_subsegment
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged deps
+ tests/ext/aiobotocore
+ tests/ext/pg8000
+ tests/ext/psycopg2
+ tests/ext/pymysql
+ tests/ext/pynamodb
+ tests/ext/sqlalchemy_core/test_postgres.py
+ tests/ext/django/test_db.py
+ # Internet access
+ tests/ext/httplib
+ tests/ext/httpx
+ tests/ext/requests
+ # requires old package vesions
+ tests/ext/aiohttp
+ tests/ext/django
+ tests/ext/flask_sqlalchemy
+ tests/ext/sqlalchemy
+ )
+
+ epytest -p no:django
+}